summaryrefslogtreecommitdiff
path: root/dev-python/python-lsp-black
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/python-lsp-black
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/python-lsp-black')
-rw-r--r--dev-python/python-lsp-black/Manifest2
-rw-r--r--dev-python/python-lsp-black/python-lsp-black-1.2.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-lsp-black/Manifest b/dev-python/python-lsp-black/Manifest
index 53bc5b77199c..d34c39cbf6d4 100644
--- a/dev-python/python-lsp-black/Manifest
+++ b/dev-python/python-lsp-black/Manifest
@@ -1,5 +1,7 @@
DIST python-lsp-black-1.0.1.gh.tar.gz 7013 BLAKE2B 596ef3f468524269fb2765ad7ba0f8305c9e67ec4cf826dbe68ea20058f1fc595c004b34c5228c14a70b6a489e29f370fef93cd7a9ef48d24ace3464ec7cd011 SHA512 43699438bf64b9cfb5dfa97b30385870a06d15be90d5a023c5282f1b969188e8536961c2a2ee6f1016d4b8188e4df6a81d6127dd628242bbcd3fbcc640504a24
DIST python-lsp-black-1.1.0.gh.tar.gz 7547 BLAKE2B e362e3800763b28c9505e9548f2324299fac5db792cc98755b2f3e5db02cec3cf0061193aa5dda40a843f2db0abfc252b8ebf6ae12a403953bb334155e90b028 SHA512 47c1652e7c1732a01d0eaa29c3b36adaa484b4b61aed8f6a99967c734d43353173716946cd15ea247974ee7801daa57e34979f5ed9b52eb88fdf96830af8bd19
+DIST python-lsp-black-1.2.0.gh.tar.gz 9226 BLAKE2B a9efe698c32ac86060f360e1d1129620783d0dd1588cf16b6f96a4f805845d5c94e862b265d63643e877afc68916ad0fbbe922fc0c17e224ea08f61756a3fb41 SHA512 b5f999b0e02abc63dc194a2973f028aa5f74b3110d0ac35e6aefb45a4260bf3fb5b1f142f71a85feec431765af98409977a47039d28a79cfac5746cc677794c7
EBUILD python-lsp-black-1.0.1.ebuild 598 BLAKE2B 0483ce22694575062b150aff7ed7d7930680542d437cf795fa0c932328989127072a432498d6b338dbb40e9dab2d66c6266fb4540929e68bb67c2284fa170ded SHA512 a3efbd9b3274d7b90dc91661caa1a16ac0eddbf62d2acd8f5fc7a7b1cdf6c5071ed5d0b71057b4654c5592c47b31e9101c32bcd1f598621c654df89d21241ec7
EBUILD python-lsp-black-1.1.0.ebuild 679 BLAKE2B 463d6b6becb428d15435c2ad9495d20ecb88c700da5a06d9f1c818dbb10a02b5b24b8a0e3946bb644eeaf247d19f23a47fdf4fad3aa1a8a14980c1ef7da339ae SHA512 84ef8bb4f5dea61c4225ab11f9f21d9b09ac99f59f445be536529e5accfa8f8180462636866cd7bf1edcde813337d32bea2b90b4315a92cce6c04e49623dc32b
+EBUILD python-lsp-black-1.2.0.ebuild 705 BLAKE2B da5d5e47dd34785ed6dabe68e3496a34b93de7048398f2667f45d535a3e4c35ac0dc4e223b28805acf5cb78a011ae0098f8e57121f231d12246e01b2867c12ec SHA512 540bcade3c3b7f0ef35b63addee25aa7b0bd16579ce0b158af6342b1b58468019baf06c680fa1cad51a2db4005f313e3efe12db3b2c02c1d78dd3aef96a82d2a
MISC metadata.xml 429 BLAKE2B fcfbbc17f713e9f33164eac55cde53fb505d550a9049bf843809cb688f038912770764332e8eed56ef39972ff82e39e1a27a2d8248d887950857fb790e6a7bc1 SHA512 6a1438c96853dd9fe11eceaddc7e350311db01a95f17fa05b3f2cf651ae778b5361b9612423c2d124bf4dfdaccea836538a3aade91dc58efd4feb81dba23ada7
diff --git a/dev-python/python-lsp-black/python-lsp-black-1.2.0.ebuild b/dev-python/python-lsp-black/python-lsp-black-1.2.0.ebuild
new file mode 100644
index 000000000000..8525c6e386f5
--- /dev/null
+++ b/dev-python/python-lsp-black/python-lsp-black-1.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Black plugin for the Python LSP Server"
+HOMEPAGE="
+ https://github.com/python-lsp/python-lsp-black/
+ https://pypi.org/project/python-lsp-black/
+"
+SRC_URI="
+ https://github.com/python-lsp/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-lsp-server-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/black-22.1.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/toml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest