summaryrefslogtreecommitdiff
path: root/dev-python/python-ldap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-18 17:04:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-18 17:04:41 +0000
commit6cdde4bf2702fac82ba7163fe9f922e7fa0b9a66 (patch)
tree876fe918d1abfd24cf9323208d2929b94a47cfc7 /dev-python/python-ldap
parentce89e807ecd2194613ad6e6bcee8cf95e982ad1a (diff)
gentoo auto-resync : 18:11:2023 - 17:04:41
Diffstat (limited to 'dev-python/python-ldap')
-rw-r--r--dev-python/python-ldap/Manifest2
-rw-r--r--dev-python/python-ldap/python-ldap-3.4.4.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/python-ldap/Manifest b/dev-python/python-ldap/Manifest
index 16df4d7abb8a..69835c098969 100644
--- a/dev-python/python-ldap/Manifest
+++ b/dev-python/python-ldap/Manifest
@@ -1,3 +1,5 @@
DIST python-ldap-3.4.3.gh.tar.gz 378215 BLAKE2B d5c165e668ed8bf1415e06e28e306bb757dea71ee7cc1ad380c35a5d911767fd08e249577aef0e5e888c1e9129072f93f499560e8b70e6848fbad4d7f9bb95a6 SHA512 a52403b7d9fc4d114b995640ff34f5aefd313d36cea5ff6de73ea9f46036694ebd43cd9d11382daf3be9da887f62c6675b49d684c05a7d5f0c93d446b16d1981
+DIST python-ldap-3.4.4.gh.tar.gz 378862 BLAKE2B 05a0f9696b888f56ea51f4cdfc21e3c67b10aec8d1d300c1f6b26d23285d81e7a126e0e56e4a8343a5c1f35c919ef340287dc9109d26ed146e1d64a0831b722b SHA512 de87bc6f64540969d1a0ec003f2518c4e8a1899798085371ed017209702fe0c580eea235def8208a5aea42541011b2515c982924f6a75558a84b3f01785254ae
EBUILD python-ldap-3.4.3.ebuild 1708 BLAKE2B 92f8bdb003b73042d7dd74cdb23e7b14333c370eac0f01ffdf07dc99ef1017f1031ee4c7c598b94bc0c396290ade9279a74fc6e331acd7b0dd1dd12c79f3d031 SHA512 c097a4436e9fc6d7ed55d37e6144814cc158d46959d0c52013660797ed28d11ca545063362c8bcbb2327a40fdb0b8d3702ab7728e6004155bfb2fb690f57ac1a
+EBUILD python-ldap-3.4.4.ebuild 1712 BLAKE2B 07493d6afc6a2c9a04cb08a8a65210ee57118994ce11acc6557e04a6480d1801e216a3f5e0c93366144b516fd13a4b613e3d7e649c4107943bf2f8379bf98278 SHA512 9d883ba9b83f79e164ea0641cb922021d978cf46e60319a1b2743602899265adc3bbce58c1f32ba6f0b725f158b8a2ab5b138ff0d0065c054f2742349783a655
MISC metadata.xml 449 BLAKE2B 14ffa18ca09eb663d3ef4ff5bd0ebc8511fa408a4e96c93885ba2beaccdf3bb82a9733a01149e088c8b66d6cb938f94fc3940c0c0cca5685599191e772443cb6 SHA512 2f5c014e55f838b84abf6ba630b000620a01e2fca6d1f1bd1b30db309f820df50c2ef7feddc17c69ee0188c3cbc91a388933b4bccfc8d2ea0cb18c6dae85cda6
diff --git a/dev-python/python-ldap/python-ldap-3.4.4.ebuild b/dev-python/python-ldap/python-ldap-3.4.4.ebuild
new file mode 100644
index 000000000000..b6b0d8598aa1
--- /dev/null
+++ b/dev-python/python-ldap/python-ldap-3.4.4.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Various LDAP-related Python modules"
+HOMEPAGE="
+ https://www.python-ldap.org/en/latest/
+ https://pypi.org/project/python-ldap/
+ https://github.com/python-ldap/python-ldap/
+"
+SRC_URI="
+ https://github.com/python-ldap/python-ldap/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="MIT PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples sasl ssl"
+
+RDEPEND="
+ >=dev-python/pyasn1-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.1.5[${PYTHON_USEDEP}]
+ net-nds/openldap:=[sasl?,ssl?]
+"
+# We do not link against cyrus-sasl but we use some
+# of its headers during the build.
+DEPEND="
+ net-nds/openldap:=[sasl?,ssl?]
+ sasl? ( >=dev-libs/cyrus-sasl-2.1 )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx Doc
+
+python_prepare_all() {
+ if ! use sasl; then
+ sed -i 's/HAVE_SASL//g' setup.cfg || die
+ fi
+ if ! use ssl; then
+ sed -i 's/HAVE_TLS//g' setup.cfg || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Run all tests which don't require slapd
+ local EPYTEST_IGNORE=(
+ t_bind.py
+ t_cext.py
+ t_edit.py
+ t_ldapobject.py
+ t_ldap_options.py
+ t_ldap_sasl.py
+ t_ldap_schema_subentry.py
+ t_ldap_syncrepl.py
+ t_slapdobject.py
+ )
+ pushd Tests >/dev/null || die
+ epytest
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r Demo/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}