summaryrefslogtreecommitdiff
path: root/dev-python/python-heatclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-python/python-heatclient
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-python/python-heatclient')
-rw-r--r--dev-python/python-heatclient/Manifest2
-rw-r--r--dev-python/python-heatclient/python-heatclient-1.16.2.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/python-heatclient/Manifest b/dev-python/python-heatclient/Manifest
index 6b3c135f8a9a..81f8baa1b62f 100644
--- a/dev-python/python-heatclient/Manifest
+++ b/dev-python/python-heatclient/Manifest
@@ -1,5 +1,7 @@
DIST python-heatclient-1.11.1.tar.gz 166963 BLAKE2B 340c9f1ed054815176af8da9b3035d8e260730fdd389317190281314af7b3df60214dc780036b098a15485bf2cd5b02010eacaf474746a73d7d7ee94972c14da SHA512 f4ffc4706a2630753c11423270ef18a344603ec6b1d5afc550fb8f3cfeca1bf4fbd0c32670318eded6b81a810fcdff68faf9039c6290c6a106bf8618502efe78
+DIST python-heatclient-1.16.2.tar.gz 173543 BLAKE2B f5b4016166bba804a2704b2cc3203438e7ebdae429f85b74e89ccc6d1b2db2de32d4acc6622138b211f5d8657876001b83977d55d56f0cd5906df99eb92a429e SHA512 eb566e5c0270a0cdb8994194a757102febf88869a61bec65e345fd62f8ae9c0b3609bf27f758d37088d69d2227cbbe086960123feebfae7f543ba2bac2133b0e
DIST python-heatclient-1.8.2.tar.gz 165073 BLAKE2B 32f09850f2da3ae3235dd8a7f683529189db6a97712374bb2a387c87fe61a74b132d7b51c3fc77e0fffbfd6d8f2596ee097102f034d5fe029b8a08ceb0e31500 SHA512 38c27dff97c8bf9826e57c02fdd5edb4c0410ccc041b7b1f2e95aa16b22d46cfd9a8b728bbd371e1dee0664aa1f8e14b4eafc6bbaab92a038abbb821e3c8dd34
EBUILD python-heatclient-1.11.1.ebuild 2662 BLAKE2B 7bcaed68fb7c87afa29b19be5b064f9dd52d184fe5c288c798fb371d2d82672b6513e4bedb9609e3a0dd0f31c0bac413d26f649e651335a0978e6f54eb53f8aa SHA512 5614b413daa403736eb3f85d9b06e949af48a28df1a3bfb75e74d4b0ef4d05ffd0774a0672bc40bf5132212c9e21e1aebe9ecac75f7aec2cd70fb4c894031bac
+EBUILD python-heatclient-1.16.2.ebuild 2805 BLAKE2B 05daf0e3922eee5378aa6b1085f4c7c32a7968a65ea58beacceba46e0a1d3be759237690c4a37ed305898b490b87f8169ec372e04f2dd6d78540aa52430fb409 SHA512 a6e768e7734a7903d4581a94b7206dd2719732962b8cea3ed9921081bd115fea88b589e4ac8e7bd5b3f94f32760b75b81d8ec39d9ed203f2c5035fbe48e005fa
EBUILD python-heatclient-1.8.2.ebuild 2410 BLAKE2B 9c0c211d7e2fb0187a8f1f77c5aa1960c76a3254e470147714a9707960090608b6c740189b831d085621278e154a5e9cc30009a39381b2e7dd87306b85a6e0e2 SHA512 95f5ecea31d0160089447e68d624dca7b8ba4c7f0c669847c4dc046feefebc7fd5db9e235bcc3ffccdf36afbe90b11b2f30785663d95b7341d88181e4a998bed
MISC metadata.xml 582 BLAKE2B 51e093bfad4008e3d662b8eb5d3714815f7ced2ce68867b2b4dddceff4cad927a60b84706dbb14a36609720e96259a744460a3cd82a068810e1de6173bcf7dc1 SHA512 b0af42a00c8e7e226f912a056edf53b3fdaf356457fd76edd34cb243d45e7f6427fac8bebd39e1aad57c0d16da8e222b3c6414fa9c5b85728294032afdf5804c
diff --git a/dev-python/python-heatclient/python-heatclient-1.16.2.ebuild b/dev-python/python-heatclient/python-heatclient-1.16.2.ebuild
new file mode 100644
index 000000000000..089206d199f5
--- /dev/null
+++ b/dev-python/python-heatclient/python-heatclient-1.16.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Orchestration API Client Library"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-httpdomain-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
+ )
+"
+
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ !~dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/python-swiftclient-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ sed -i '/^tempest/d' test-requirements.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init
+ testr run || die "testsuite failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}