summaryrefslogtreecommitdiff
path: root/dev-python/python-glanceclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-03 20:56:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-03 20:56:28 +0100
commitfbda87924e6faa7a1919f1a2b4182490bde5ec5c (patch)
treef3114a4ed212a754756adce027aeef3a4a1a2e2a /dev-python/python-glanceclient
parent3b08f674e3f771b49370edb144dab0958c8cf721 (diff)
gentoo resync : 03.09.2021
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/Manifest1
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-3.2.2-r1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index e2b44697c194..a8dea21bfb9a 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1,3 +1,4 @@
DIST python-glanceclient-3.2.2.tar.gz 191501 BLAKE2B 0ccafb81aa01f35313a6d312496538b0a3c7f2b8df9f0523b244fdcaf55eedb48a7b9beb750b56df2303bf0e4f32e6cd85bdb998618584bae05f36db606b0eed SHA512 900c8120f2a06f2bf5016ea22883b78926c5b8b27782692f3e44a473985e31cd8c6285371ef16f61dfac79828add8d841363f043453cd68ca6ddb31c8c126606
+EBUILD python-glanceclient-3.2.2-r1.ebuild 1392 BLAKE2B 1a4bfa38d923bcb6b3eff021fb0b8dda2b0d62827f7032ad90bdab24f794c32f258cd703e53456b1560cbf36a64430e6ed59774ad440e73ecdcac54132a332e2 SHA512 4a56e02db0554be08dba952e0594ee220466a0258d9b666f982995860d0a7ce5f90f9db3c14ec17e513a2b8b246b8e15cd2f6aa59d975c556bd66a4136c5ee58
EBUILD python-glanceclient-3.2.2.ebuild 1055 BLAKE2B c85d385b2a7a50545fb9d0b43962d4e37807d58c4912408a06fa9151ea2777693380dcb19df84308255c3e45adae24213bfa9c77413c98cf4ccae6747816b5eb SHA512 5085edc18ab762512491fd1ce665f86bf5251ff985eb02a7ada5ec54a38b5825ab72d79f3490261916bed89266ca0038a66e19d4904e876fcbbe45e57b95e017
MISC metadata.xml 555 BLAKE2B 47cd49b9ef19ba749237a7dadbb62859993db80e3962b89fb99a0682f86d34cd3add1248ba690bbd6fabc0b4056e9b0be3ca2ccbc86a911b0daae8b50407db09 SHA512 daa2004c4cd2e0ead561d71cc3dfe3a273cc8ffc1c431eb6b3fa5cbce065c526f7dddcb169ff4956c2b203d5f984ade3e261c388249a87f8c6f3ef1df391ec38
diff --git a/dev-python/python-glanceclient/python-glanceclient-3.2.2-r1.ebuild b/dev-python/python-glanceclient/python-glanceclient-3.2.2-r1.ebuild
new file mode 100644
index 000000000000..e0999c504f89
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-3.2.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/keystoneauth-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/stestr[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" -m stestr run --debug || die "Tests failed with ${EPYTHON}"
+}