summaryrefslogtreecommitdiff
path: root/dev-python/python-glanceclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/python-glanceclient
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/Manifest2
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-2.17.1.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index acc84ad90572..a8a6ef2cdf25 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1,3 +1,5 @@
DIST python-glanceclient-2.16.0.tar.gz 189395 BLAKE2B 9de8b162c1eb5bfb44700f41cbdcd4f8a983d8c7bd7b281df09db67df6a0de5dee905330f03c967be9e1c3b2aaa379e4c8594f7f4cdbb34870a1e87cb7ccaf1f SHA512 b853f529752247873d9f319d4ec6f4cabc89ee4c26a0c1013e7609fc38e3c9f68d774b3682166e8155e21572a0a011eb6859a84c253ca9f7a9b8b1ccf79b5322
+DIST python-glanceclient-2.17.1.tar.gz 189763 BLAKE2B ef085f6e6e0b8d3c79ab3cce95fdef2066a999258e511fe3c5efa9be577990d8381f07929ead4e83d1859f345ea55629ab75f980d04107e41fec192a64c6f055 SHA512 2082112ce01292b232f63a0a8a95d16f209f33db5c9b81ddc912cef2ce378d5f0bc7ea0e039c0608ab382f3e9f6efe020d71e94b5475391c4d41fc1fca45678e
EBUILD python-glanceclient-2.16.0.ebuild 2006 BLAKE2B d68ce198d7957649f5e6bc5c58e6be0a14a161780d9a3d63e399362cd707a3a22241760306b997547e0dd1474c14bc91a70626929fb903456b1285dde715cd43 SHA512 7de48e04276b2c2fea7efe5a5b9bc1b520231d896b2f42c7456b82b8c87ceb16183b2698f5cfbdcc4f8ddef52a806dbf8862b263eb8fb567d2ed7afab7d11bcb
+EBUILD python-glanceclient-2.17.1.ebuild 1103 BLAKE2B 3275d4f7928135ff0c4a51a98096be02297547ac1e742cbca9398154129dad6c670d083fad724ecca07899b2eb283b443f712e9ae89b7694c9ead50bb9e4d526 SHA512 b4ad474670195a4e94354a05e74ce2d2bc06fd30e99f364bc0178dd874526821027856843245d787aaf6fca6498097eb351bd53a86c4973dc3d8b8a75a37917d
MISC metadata.xml 530 BLAKE2B 8b986229c3bfbc1b53f64a82ac7dee2928b57d5ef6ea57f2ac46c112e058005d9ce617ea3adb4d8d0df1e43ecc74b3b6d07b675dbbcb96527c7a3139b9790a16 SHA512 369ad6988a7f6c068c62bb5d7139c6bf807ccc29a2d8ec314c8f4156b41690291b7243f4f6562f16aa8733211513838e4916a67fad1cda6d1ed698cbc14b843a
diff --git a/dev-python/python-glanceclient/python-glanceclient-2.17.1.ebuild b/dev-python/python-glanceclient/python-glanceclient-2.17.1.ebuild
new file mode 100644
index 000000000000..e04d9c12203a
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-2.17.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+"