summaryrefslogtreecommitdiff
path: root/dev-python/python-glanceclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-18 21:36:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-18 21:36:58 +0100
commitea4d97bae88695501ff5f5c646a57e2e0488e423 (patch)
treeafc4100ae641b360049e5bc3a2e1cc4c408641bb /dev-python/python-glanceclient
parenta2f7cdda45fadf1f967379421e8d808b1a503cd3 (diff)
gentoo auto-resync : 18:08:2023 - 21:36:58
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/Manifest2
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-4.4.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index 2c79956733c9..6165851f3065 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1,3 +1,5 @@
DIST python-glanceclient-4.3.0.tar.gz 205005 BLAKE2B 63f99858e4fafd041a99a34e3a0a22403f637d2317fe236fd9da55f84f7bc58b410fe4b859af2cf7ccc8cb4f8cf17f80e57afa846a9f33e9a54b1da069f6a6ea SHA512 7f381a6f997b8d1c73c9d2bafa14ecf3d4899640f28d669b7b4762a9c01d8df366b616f0be9bc00c7ea4561f407adceb8d10e721d12d4f5fb5790fd4cdb7362d
+DIST python-glanceclient-4.4.0.tar.gz 205612 BLAKE2B 8a1e31eb8dbefe4b08e945377bb190264332cd01066b96ec061e8839a45294ed6cf5ab08fd89d97b57bc072987ce04d19f94a887d5e8eaa10760d996058122bf SHA512 31d2994fef3298f790a3ec268b26d432602a6b73265277e961ff2b47df2a84028253da8b2090193e1e65c55ab6e4b40413a16d01a653b90cae926545ea4097ae
EBUILD python-glanceclient-4.3.0.ebuild 1488 BLAKE2B 66c16c78ce7162a8f6bedc5df012da83e851db7d13cccb232f912c80dac8801d249f3852f22e7026db9fe86b160345077afcea1eff7d89fd2e40239ab40d56b2 SHA512 e6ec74acb91f7d2399e577f49ec9c46a1120855c0f80631b75ac5f6dfdeedd277f3a6ae0e3a791ab91ece9ac3883b165f516fb6938a2f20349fa2514ca8136b0
+EBUILD python-glanceclient-4.4.0.ebuild 1492 BLAKE2B cdeeb3017567759ebd08d74051068742224281d18752d016e7df582923d61031b9ded6b0a2a328e9ff2a1ff98aa743a765fc83872a977a9bcc7a38ecc02c90bd SHA512 71958a9cfae9ed317f5040d733733af43bf7943f22b76c0f61bc0dee70a3c90f4b8c32be9b4c422237d2014356d021241c0747b640208f2b3db4baa71bc6eb3a
MISC metadata.xml 663 BLAKE2B 642540f3f4d577797725731f2374b5801ec2d4ad799ee4ccfaa4e29d955bd93a8ade0e6c9ec7712ee27d9f1f93186854472d301016a732020575b8f7bc1c5138 SHA512 fa9b88dce5a10824dd0d6987698587666343c95d8b6c607e466f14883c34fb0ebc846b683ae7d8bb65efe88007e6db0d2b1b41ba389c3b656a24f1839d03d9e2
diff --git a/dev-python/python-glanceclient/python-glanceclient-4.4.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-4.4.0.ebuild
new file mode 100644
index 000000000000..b942bb5bedc3
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-4.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-glanceclient/
+ https://github.com/openstack/python-glanceclient/
+ https://pypi.org/project/python-glanceclient/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth1-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b glanceclient/tests/unit
+}