summaryrefslogtreecommitdiff
path: root/dev-python/python-glanceclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-01 23:41:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-01 23:41:30 +0000
commit1331637681273dc8391d7a7caa6175405dceb735 (patch)
tree57acd1953dffe9d8e88a0735a76115e20fa09d26 /dev-python/python-glanceclient
parent5d5b0e27ed33330cca5636eb792368fbbf46774c (diff)
gentoo auto-resync : 01:03:2024 - 23:41:29
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/Manifest2
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-4.5.0.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index e98a46417511..f757fd8cbff5 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1,3 +1,5 @@
DIST python-glanceclient-4.4.0.tar.gz 205612 BLAKE2B 8a1e31eb8dbefe4b08e945377bb190264332cd01066b96ec061e8839a45294ed6cf5ab08fd89d97b57bc072987ce04d19f94a887d5e8eaa10760d996058122bf SHA512 31d2994fef3298f790a3ec268b26d432602a6b73265277e961ff2b47df2a84028253da8b2090193e1e65c55ab6e4b40413a16d01a653b90cae926545ea4097ae
+DIST python-glanceclient-4.5.0.tar.gz 205909 BLAKE2B 5e48abd2c869d4f3a0bfbfc593950754fd165bd36a98bc4358d88a1b64f6892b6633f10421999733c014fe8f1664d1181b5019739997139c1ef5d604194cfda8 SHA512 141f03fa55012981214283e961c4d4020a2fa4dc87b7cbc323d87c536b88e98f4798b59d83dc627a5846c5437fdac963fb34a3db444c20410a01441bf5838fa7
EBUILD python-glanceclient-4.4.0-r1.ebuild 1447 BLAKE2B 40c40c23b254d7a10f601302f303e116ebb1e11fe3a2dae611f618b3e7fc3f87a44e7696b3a2f759dbcef55247db40619bb0c6898936a18d2ded3e33da6d4b66 SHA512 42efacf1d4b5cee415f527472033c4f89d6e274523ea82b08f8db4e088f50e97b91bc0c80277807cb619ee89673582eb98ceb3b84c8260e7366252502fd3ab5c
+EBUILD python-glanceclient-4.5.0.ebuild 1450 BLAKE2B d58d4dca81d4b85d005cb7deece8138cca60df7154e7b07d90a5115d7c1a61a48c37f42d5e8919fd8462047a96fabddc337af7019f342691054d51e681a27fa2 SHA512 092c588db974c8facee2b5baf8a5ed721fb3110a2dd1e67b7e8f68a450206513648dceb7d6bea8a841820ff2a605502504a8d5704177843ffc219da2ba00d307
MISC metadata.xml 663 BLAKE2B 642540f3f4d577797725731f2374b5801ec2d4ad799ee4ccfaa4e29d955bd93a8ade0e6c9ec7712ee27d9f1f93186854472d301016a732020575b8f7bc1c5138 SHA512 fa9b88dce5a10824dd0d6987698587666343c95d8b6c607e466f14883c34fb0ebc846b683ae7d8bb65efe88007e6db0d2b1b41ba389c3b656a24f1839d03d9e2
diff --git a/dev-python/python-glanceclient/python-glanceclient-4.5.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-4.5.0.ebuild
new file mode 100644
index 000000000000..6930cb7e8b95
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-4.5.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-glanceclient/
+ https://github.com/openstack/python-glanceclient/
+ https://pypi.org/project/python-glanceclient/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth1-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ <dev-python/urllib3-2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b glanceclient/tests/unit
+}