summaryrefslogtreecommitdiff
path: root/dev-python/python-gammu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-27 22:02:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-27 22:02:09 +0000
commita87296ad796f00f3bba27339f6efe11b9a384e23 (patch)
tree1a47aa193935e1eb80c6ce1c7ececdcf9d44dfb3 /dev-python/python-gammu
parent724cccb689f2076a398ede6845749926c86ea647 (diff)
gentoo auto-resync : 27:02:2023 - 22:02:09
Diffstat (limited to 'dev-python/python-gammu')
-rw-r--r--dev-python/python-gammu/Manifest2
-rw-r--r--dev-python/python-gammu/python-gammu-3.2.4-r1.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/python-gammu/Manifest b/dev-python/python-gammu/Manifest
index 78f10ab67f04..24cd314e2cef 100644
--- a/dev-python/python-gammu/Manifest
+++ b/dev-python/python-gammu/Manifest
@@ -1,3 +1,5 @@
+DIST python-gammu-3.2.4.gh.tar.gz 144136 BLAKE2B ef06b78568e9b88da95d09029191a2de0c4e26cb6b222326bffd0134a9c7eb743bab20201347d3be8a81db43f6005ec2a0550e1976a59de9ee9202c733ae41e0 SHA512 9d76b402c50018cc52476376952edebb6b0934aa374ea2a2177f5497d0949fcc77644aa2a35c7402b3f2179962d903409b7b1949c5e85a0e5130058d34f89664
DIST python-gammu-3.2.4.tar.gz 144136 BLAKE2B ef06b78568e9b88da95d09029191a2de0c4e26cb6b222326bffd0134a9c7eb743bab20201347d3be8a81db43f6005ec2a0550e1976a59de9ee9202c733ae41e0 SHA512 9d76b402c50018cc52476376952edebb6b0934aa374ea2a2177f5497d0949fcc77644aa2a35c7402b3f2179962d903409b7b1949c5e85a0e5130058d34f89664
+EBUILD python-gammu-3.2.4-r1.ebuild 1001 BLAKE2B 7bca59f0fd0ad5f5c3ffb09bf9b000ba3f3c5792ea199610b57246781257bb00554fe3e4dc15a2ba1fadf88aadc000d5c517e7d040c00a7b37e4bab9810a281d SHA512 da46f60096daab5fabdc2bf818398e83f86e79bf4c12a41a22cd8c11065335f8645ca96d7d6c4b90009a2c7a5f3a062a157ed8509ab6a012b3283cfd0fd8aeca
EBUILD python-gammu-3.2.4.ebuild 827 BLAKE2B 4987ea19d8fc2cebd7fc1a4f7945a8e8fc542df85e715b18474b5658df5944e683d9ed014fb19c0aff3391f7968f385d52bc4957089928d9d68d7dca138db663 SHA512 7c49203312e78afb98e696f648d7fdbf701c6969b9a252f01d813b8fe8c6abdfc9c62c6d2ab21d08543f1503ff72cfb6e5304859a649cbae721e9ac1031fa22f
MISC metadata.xml 299 BLAKE2B f8e1c54ab09e004a0f87f87a793af8d1dc6b97dfc1fbd07183407e9f6501b5c0aada63828495d5645d37a97c4e8ef3ec44e5c5771c4721e5a6d5c00008c586ad SHA512 6308e513011c0966d9c535f5ca153e38caa4bf843143fa3aad57e36e94d50f7e97232e62b8611045158d8e1f0741f70247e9ee799e6227f5497d1133c6dc1832
diff --git a/dev-python/python-gammu/python-gammu-3.2.4-r1.ebuild b/dev-python/python-gammu/python-gammu-3.2.4-r1.ebuild
new file mode 100644
index 000000000000..9ac1f19a9373
--- /dev/null
+++ b/dev-python/python-gammu/python-gammu-3.2.4-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Gammu"
+HOMEPAGE="
+ https://wammu.eu/python-gammu/
+ https://github.com/gammu/python-gammu/
+ https://pypi.org/project/python-gammu/
+"
+SRC_URI="
+ https://github.com/gammu/python-gammu/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=app-mobilephone/gammu-1.34.0
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ $(python_gen_impl_dep sqlite)
+ app-mobilephone/gammu[dbi]
+ )
+"
+
+DOCS=( AUTHORS NEWS.rst README.rst )
+
+distutils_enable_tests unittest
+
+python_test() {
+ rm -rf gammu || die
+ eunittest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ docompress -x /usr/share/doc/${P}/examples
+ dodoc -r examples
+ fi
+}