summaryrefslogtreecommitdiff
path: root/dev-python/python-evdev/python-evdev-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-18 14:34:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-18 14:34:47 +0100
commit3a1b8b124a5b405562b6e0ccf04e7bd2ddc131a4 (patch)
tree586b06fa140c17c92f004998807e894c1874db27 /dev-python/python-evdev/python-evdev-1.6.0.ebuild
parente0d23d9d2468ec36070ef9fa63bd814db6a653da (diff)
gentoo auto-resync : 18:07:2022 - 14:34:47
Diffstat (limited to 'dev-python/python-evdev/python-evdev-1.6.0.ebuild')
-rw-r--r--dev-python/python-evdev/python-evdev-1.6.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/python-evdev/python-evdev-1.6.0.ebuild b/dev-python/python-evdev/python-evdev-1.6.0.ebuild
new file mode 100644
index 000000000000..2399c0a71faf
--- /dev/null
+++ b/dev-python/python-evdev/python-evdev-1.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for evdev bindings"
+HOMEPAGE="
+ https://python-evdev.readthedocs.io/
+ https://github.com/gvalkov/python-evdev/
+ https://pypi.org/project/evdev/
+"
+SRC_URI="
+ https://github.com/gvalkov/python-evdev/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_uinput.py
+)
+
+python_configure_all() {
+ esetup.py build_ecodes \
+ --evdev-headers \
+ "${ESYSROOT}/usr/include/linux/input.h:${ESYSROOT}/usr/include/linux/input-event-codes.h"
+}
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}