summaryrefslogtreecommitdiff
path: root/dev-python/python-etcd/python-etcd-0.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-etcd/python-etcd-0.3.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-etcd/python-etcd-0.3.2.ebuild')
-rw-r--r--dev-python/python-etcd/python-etcd-0.3.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/python-etcd/python-etcd-0.3.2.ebuild b/dev-python/python-etcd/python-etcd-0.3.2.ebuild
new file mode 100644
index 000000000000..b0c24014f0e5
--- /dev/null
+++ b/dev-python/python-etcd/python-etcd-0.3.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python client for etcd"
+HOMEPAGE="https://github.com/jplana/python-etcd"
+SRC_URI="https://github.com/jplana/python-etcd/archive/${PV}.zip -> ${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/urllib3-1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"