summaryrefslogtreecommitdiff
path: root/dev-python/python-email-validator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-22 12:52:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-22 12:52:10 +0000
commit736633fa866abdd7c155cabb02adf278c5237640 (patch)
tree847aff3277bceae8b34d29ff6c16cac3ad4b288e /dev-python/python-email-validator
parentf926b97bb4ca0ec30c10ee9075bd3fd3b1df2be7 (diff)
gentoo auto-resync : 22:01:2023 - 12:52:10
Diffstat (limited to 'dev-python/python-email-validator')
-rw-r--r--dev-python/python-email-validator/Manifest2
-rw-r--r--dev-python/python-email-validator/python-email-validator-1.3.1.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-email-validator/Manifest b/dev-python/python-email-validator/Manifest
index 3bbf9f604a90..e8c205de949f 100644
--- a/dev-python/python-email-validator/Manifest
+++ b/dev-python/python-email-validator/Manifest
@@ -1,3 +1,5 @@
DIST python-email-validator-1.3.0.gh.tar.gz 28555 BLAKE2B 7b13b4093be2b97260d01c562a205d299570e63bfba2f8e411000bc19319e9b538e95f2f4d33962b03fe5dc47c3690b8a0134b792f6822386ab6b20b260a991e SHA512 b10139f8eb221fa15a12c44f2c87d17449e317c6edfd4c6a99dc122a9178dcc4c3ef20f99f0feefb6a5b4a9460169b22d835871d2be88efd59f1474ff3d9aa06
+DIST python-email-validator-1.3.1.gh.tar.gz 28691 BLAKE2B eb69028066e969a935117f51a32d75595468797a82608bcb7f6ebcbebada01aac29e3e223efc849dc519d85897a375cdc584760f3cb5a431e2c39aa566c20514 SHA512 7806ef35c07cf0cfef3d8c6c7fe6dd3cb58da091a134b57d879a2cfcdf6425f8729ab8b03194135749ae47b369da47434c1d130432cfaa8eeaf5d07149c15dc2
EBUILD python-email-validator-1.3.0.ebuild 1393 BLAKE2B 6d324c6f5d1e8168fce94318f9442ba56be3145be51e13a225a4552f548c3b2aab0074799cd56907fafa33c1b0da5086c81f17c07d5b596422c30b600061fc65 SHA512 9fcfb4934e63a335a83da858a01395d0daadebf103b507a93afb28121a2b25b33f9468c50ebaeb8a79e40aefaa29c366baca48b25e505181ce612f5ddbd69660
+EBUILD python-email-validator-1.3.1.ebuild 1401 BLAKE2B fe9303c05a373ad8a72757e854382d448d003c7b5fcd4296b4c2f6ef295bc8e29fb3239655049fa7833ea37a1bf6b3770a1f4bbc44df225e5a9271fcd80022b3 SHA512 caa66d06948dde21b8057e8aa1d1f338a4f945cce9766fe694374e641ef9a52855b1a8bed97fa1e407d4f65a9de323fbf2abc8a4e7269fd5fe26f65c78fa8666
MISC metadata.xml 792 BLAKE2B 8655d15948883c5b7ad17e943028e0ab70e09d17fe7591c5e094bb46cee2595db382a008fe9d20121cee7473f1cf66efb1b71cdd345828be125c36fe67f376c6 SHA512 9065dee947add0fa203dd9a092910c165944dfc7ecee69c17092526fccfdccfa7864d4402314d9c25389f26b161251dfa58eaf2b21113da0642a62976abd50d7
diff --git a/dev-python/python-email-validator/python-email-validator-1.3.1.ebuild b/dev-python/python-email-validator/python-email-validator-1.3.1.ebuild
new file mode 100644
index 000000000000..cdde06720d0a
--- /dev/null
+++ b/dev-python/python-email-validator/python-email-validator-1.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A robust email syntax and deliverability validation library"
+HOMEPAGE="
+ https://github.com/JoshData/python-email-validator/
+ https://pypi.org/project/email-validator/
+"
+SRC_URI="
+ https://github.com/JoshData/python-email-validator/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="CC0-1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # these tests rely on access to gmail.com
+ tests/test_main.py::test_deliverability_found
+ tests/test_main.py::test_deliverability_fails
+ # these tests rely on example.com being resolvable
+ "tests/test_main.py::test_email_example_reserved_domain[me@mail.example]"
+ "tests/test_main.py::test_email_example_reserved_domain[me@example.com]"
+ "tests/test_main.py::test_email_example_reserved_domain[me@mail.example.com]"
+ tests/test_main.py::test_validate_email__with_caching_resolver
+ tests/test_main.py::test_main_single_good_input
+ tests/test_main.py::test_main_multi_input
+ tests/test_main.py::test_main_input_shim
+)