summaryrefslogtreecommitdiff
path: root/dev-python/python-email-validator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-19 23:22:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-19 23:22:40 +0100
commit4ae4e74a3a13c7c5aaebf61e650538b005204fcb (patch)
tree4abb4271a26b735b28a4eb8b69206cbcc8e7b4e2 /dev-python/python-email-validator
parentb2a3508c3634488d32ec5bbe6b4365ab27185ebd (diff)
gentoo auto-resync : 19:09:2022 - 23:22:40
Diffstat (limited to 'dev-python/python-email-validator')
-rw-r--r--dev-python/python-email-validator/Manifest2
-rw-r--r--dev-python/python-email-validator/python-email-validator-1.3.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-email-validator/Manifest b/dev-python/python-email-validator/Manifest
index b7bb9267f4dc..f1a7634d5a43 100644
--- a/dev-python/python-email-validator/Manifest
+++ b/dev-python/python-email-validator/Manifest
@@ -1,5 +1,7 @@
DIST python-email-validator-1.1.3.tar.gz 19863 BLAKE2B 10700b4c6a48c50095045b6e3c9218cd565776b26e17c1c043633e208b9fbd346162cedaa4a1116ec2fccf63b4383438c7e1aef6faf9d2ead5512af7f934675c SHA512 d9087bf56783daf389909e13652a9db8f0408badf454f6239aa20f6a5e9510619d3662cf1567a03d0b14c4bbe81644509cd12975b2aa1b544d644b6c2b2854f4
DIST python-email-validator-1.2.1.gh.tar.gz 24348 BLAKE2B 7cd19c07bd0b8c467c0f0ec15376f0677305c6025eff5a86854dfd7cad3fe6971e218e724d86d4040af3f590fe5e841e469dea7dc8526031dccb494845848630 SHA512 e758518ef114e08cca0f83c681e6ff7ec6fad54c1e0bba727ee0f8917e93040ed3873ba0207e21a4830208d98637937294c5c28d67c317dc4ad3351c7d3f99a4
+DIST python-email-validator-1.3.0.gh.tar.gz 28555 BLAKE2B 7b13b4093be2b97260d01c562a205d299570e63bfba2f8e411000bc19319e9b538e95f2f4d33962b03fe5dc47c3690b8a0134b792f6822386ab6b20b260a991e SHA512 b10139f8eb221fa15a12c44f2c87d17449e317c6edfd4c6a99dc122a9178dcc4c3ef20f99f0feefb6a5b4a9460169b22d835871d2be88efd59f1474ff3d9aa06
EBUILD python-email-validator-1.1.3.ebuild 1228 BLAKE2B 2d434fe758ed5a45f7e2858158e6266e544d27bb97f8766148c2a89e37b19b202ab4e3093286f0a2d7fa29a46a9c2632ade095cabacad6a81074f9309d6462fa SHA512 5caa7ee4aba28db692c362e14aafd988468eaf2c8a19b58661861a87dbb04fda90335e773a859656762356e122cc6e6de54b530ad9e4838ac3ac78d17f951aff
EBUILD python-email-validator-1.2.1.ebuild 1374 BLAKE2B 73d62090870886cfbd7af400621c1739737a74b2841a3ef7c8b6a31b17c78f238174c5a5d90cdf97b17d3e5421e838d8e8964647d970fb537875523b6b6fcb38 SHA512 f7ee783f90ad7bf44f36b60a1ac92c0e02177d10ef88326577b821e89f01c809bd48c02dc45bca9152a9fa9cc5a02fd8f8fda94b941d56b775be2827d28f6d6d
+EBUILD python-email-validator-1.3.0.ebuild 1382 BLAKE2B aba74cad41238dacab5e9ec9cc084fd948f6ccdad711924c2438a62814e2396901d8e08e542a03df75266ffe3b7b7f49ba4513e5e58dae0ed519dd7480d7a7e2 SHA512 bf2072c488a7d0251e358f47262117904985dbfa434aff74485115f0271b4740cc42c6af616bcd1bed1fc70ddd2c7d0dd8f6d0566fb29524b5a87cbb8c66e26b
MISC metadata.xml 792 BLAKE2B 8655d15948883c5b7ad17e943028e0ab70e09d17fe7591c5e094bb46cee2595db382a008fe9d20121cee7473f1cf66efb1b71cdd345828be125c36fe67f376c6 SHA512 9065dee947add0fa203dd9a092910c165944dfc7ecee69c17092526fccfdccfa7864d4402314d9c25389f26b161251dfa58eaf2b21113da0642a62976abd50d7
diff --git a/dev-python/python-email-validator/python-email-validator-1.3.0.ebuild b/dev-python/python-email-validator/python-email-validator-1.3.0.ebuild
new file mode 100644
index 000000000000..d1d134328779
--- /dev/null
+++ b/dev-python/python-email-validator/python-email-validator-1.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A robust email syntax and deliverability validation library"
+HOMEPAGE="
+ https://github.com/JoshData/python-email-validator/
+ https://pypi.org/project/email-validator/
+"
+SRC_URI="
+ https://github.com/JoshData/python-email-validator/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="CC0-1.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # these tests rely on access to gmail.com
+ tests/test_main.py::test_deliverability_found
+ tests/test_main.py::test_deliverability_fails
+ # these tests rely on example.com being resolvable
+ "tests/test_main.py::test_email_example_reserved_domain[me@mail.example]"
+ "tests/test_main.py::test_email_example_reserved_domain[me@example.com]"
+ "tests/test_main.py::test_email_example_reserved_domain[me@mail.example.com]"
+ tests/test_main.py::test_validate_email__with_caching_resolver
+ tests/test_main.py::test_main_single_good_input
+ tests/test_main.py::test_main_multi_input
+ tests/test_main.py::test_main_input_shim
+)