summaryrefslogtreecommitdiff
path: root/dev-python/python-efl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /dev-python/python-efl
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'dev-python/python-efl')
-rw-r--r--dev-python/python-efl/Manifest2
-rw-r--r--dev-python/python-efl/python-efl-1.23.0.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/python-efl/Manifest b/dev-python/python-efl/Manifest
index 8b3022cebd85..8c29ac3820ea 100644
--- a/dev-python/python-efl/Manifest
+++ b/dev-python/python-efl/Manifest
@@ -1,3 +1,5 @@
DIST python-efl-1.22.0.tar.xz 9523624 BLAKE2B b1b7573da8546f580dcd06be03e4746f2e991245c7bbc3477090c5a9365225bca663454a202f8e05ec6c73cbfb7496ee5f92bc2a9997900e6709b01017740db6 SHA512 27e29af764166e803ce6a833c8249a91226a4315dd658631cec57513befccdc9407b04b452054ceab3f77b429d899095b49dbada2e0fd1a63ff6059ef200e497
+DIST python-efl-1.23.0.tar.xz 9524832 BLAKE2B d738d3481a0805490c756d38fe169e7d54d9b4c8d6b18ba45265db029b28e59eec8d711675c3fcd52500e19cda8cabc49fb0a2d052d2b9be7800ff9f6dc78f75 SHA512 b2c4389795d704b8f0d8f2d0703b90b09daaeacf7a2d4b372d86f9e0b8f9e2f5b465f8651a0da7cb4bc1800357c317b9cb737afcb415fc0a4cdf4cbed62bdf85
EBUILD python-efl-1.22.0.ebuild 1636 BLAKE2B d419249cb2b75e569d16158072f7340602c67e8c23123e3fae9ec5caec66960fb0287efc431a55bd55015ff728c6f4b638da95cc04299c5abd5a0b206e6e3b2e SHA512 954bf4b4732436f78c3f5c1001f966a5ba8185f17db901a3a3197064582fa539f75265e1a5f9abaee508cc32200581eb8209bb0dc5b7592838be8fc87d7bee71
+EBUILD python-efl-1.23.0.ebuild 1628 BLAKE2B 2569d9539990cf3e0efe7315718916389f6561da16f4f0ec0827bf8152d1e854986eea44c7663ed406e82f7c29750e02c28ae97ea08f53a9b7d08f5a0f5ccd2d SHA512 5e39ec74140ccece9d89b3b2e708624a622f04d03258be37d1bedbfc777dd99ed803d2551d0cee4d74fd82ddb27a6bc2f9ec5a7cf1d1e1d735ad7804ad55a90c
MISC metadata.xml 588 BLAKE2B 0d810c31fac4488f392b8d3b57eb830af3b5ce3c970a9087939e35bc33c58d652ad3a6dd1c42c6b2604334b5c098b81465a1dc92e051e9f5b8cf5a047a190ee8 SHA512 9390fbbc9345bd5e580a8a1208d8f2e727dd0d1d562679b5e7b7c3f7a4010ed6154e1c2f9d93502dee73d96cbe28ed771b921f67e4a4921c635ada8056449de6
diff --git a/dev-python/python-efl/python-efl-1.23.0.ebuild b/dev-python/python-efl/python-efl-1.23.0.ebuild
new file mode 100644
index 000000000000..7721035b78bb
--- /dev/null
+++ b/dev-python/python-efl/python-efl-1.23.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5..7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Enlightenment Foundation Libraries"
+HOMEPAGE="https://phab.enlightenment.org/w/projects/python_bindings_for_efl/"
+SRC_URI="https://download.enlightenment.org/rel/bindings/python/${P}.tar.xz"
+
+LICENSE="|| ( GPL-3 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="=dev-libs/efl-1.23*
+ dev-python/dbus-python[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-python/cython-0.28.4[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )"
+
+src_prepare() {
+ default
+
+ # Tries to download a file under /tmp
+ rm tests/ecore/test_09_file_download.py || die
+
+ # Tries to use that file which failed to download
+ rm tests/ecore/test_10_file_monitor.py || die
+
+ # Needs an active internet connection
+ rm tests/ecore/test_11_con.py || die
+
+ # Test fails because of deleted files above
+ sed -i 's/>= 13/>= 10/g' tests/ecore/test_08_exe.py || die
+
+ # Make tests verbose
+ sed -i 's:verbosity=1:verbosity=3:' tests/00_run_all_tests.py || die
+}
+
+python_compile_all() {
+ if use doc ; then
+ esetup.py build_doc --build-dir "${S}"/build/doc/
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd tests/ || die
+ ${EPYTHON} 00_run_all_tests.py --verbose || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( ./build/doc/html/. )
+ distutils-r1_python_install_all
+}