summaryrefslogtreecommitdiff
path: root/dev-python/python-dotenv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-23 22:46:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-23 22:46:03 +0000
commit87340091ed79698e591084bd7d9d76c58c94820b (patch)
tree2feae8a3b95f1f30e68589e06e632a6abd7772cf /dev-python/python-dotenv
parent1f1ada4b2afd8dd8de6ac1e0f94702abf05654bc (diff)
gentoo auto-resync : 23:01:2024 - 22:46:03
Diffstat (limited to 'dev-python/python-dotenv')
-rw-r--r--dev-python/python-dotenv/Manifest2
-rw-r--r--dev-python/python-dotenv/python-dotenv-1.0.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-dotenv/Manifest b/dev-python/python-dotenv/Manifest
index 88e56e0b8b78..42496770ba59 100644
--- a/dev-python/python-dotenv/Manifest
+++ b/dev-python/python-dotenv/Manifest
@@ -1,3 +1,5 @@
DIST python-dotenv-1.0.0.tar.gz 37399 BLAKE2B cc5a4b810fae2a79e091a9523738be37ba030c29a373f375f2d413396f56d0606b77febddfba82085f94abc151e86b3a8d4719899e4e80e9956bea3989569dbd SHA512 8fc14eb07d8fb5e4cb4a83338aac1009aaa0715b3e7438b4ac8ee7da0ad5f7cf6b05121a685d05af7f03828ab39df61382cfbc5e95c6708246d1f400fe10d250
+DIST python-dotenv-1.0.1.tar.gz 39115 BLAKE2B 31bc0598abce2ffe5da0f248f56587fc549489c11b21e87ca144654c564701d7a5f952614b21ba12afb49a7bbb6d3753714c6e628485b449e9de2ec9513657f0 SHA512 d03f28f123b19e6e4af05c239686e189e5767108049399c110b80668bfea9d2a3f9222b719863fdef016cbe726a7a77748a18ddad013f7fc21c239ccf680c1da
EBUILD python-dotenv-1.0.0.ebuild 1001 BLAKE2B 246d8dcb882e2e43e50466bec720f64d5bfce5cfe87eb413249273d009f43754c653fda6e2bf78ddd16eff29178ebeac88fe25b091b1c8b95ece70a83b9cb4d6 SHA512 b83a4ca38998b01db17a6dcdfb80b4e60ec91e2e9d307e331004f64787407a0e773abf436a9453aa8ce427bc88b6199045472d355d5bce4ea443f735a602480e
+EBUILD python-dotenv-1.0.1.ebuild 1009 BLAKE2B a363987155011bfa1fccd8288b20dd16df9de9a539cfec8669b3b9c36c0415c0e9cf16e5a23d78b52754b416feb4a93b3b024958b659c3b4fd203555ceca729a SHA512 fa2d71fb21f419476cdd5fe28498e2bce9ffc9de1bcbcdc494b14da5ca4107b5200a5385285ffa0929f6de2a8a8e24cb34764c34b9873dec6fcf692e41e90e43
MISC metadata.xml 529 BLAKE2B 1dd381879887df2d49a80084ffd386891cffa2547fedf00bb1dbee3c3abe79759620b606a916d71cab518bb3869ecee4775c735db22aac17e785bdda5c4905a5 SHA512 ad2129cb6c691f9f4622de92701f9825cbbfe61e9c2552f91bae53c90e19abe9b4f7cd2e379c516254d8b9a5989d4861f5ec05ec7949c5b533c9b7fc6416056a
diff --git a/dev-python/python-dotenv/python-dotenv-1.0.1.ebuild b/dev-python/python-dotenv/python-dotenv-1.0.1.ebuild
new file mode 100644
index 000000000000..a36a6d24eae8
--- /dev/null
+++ b/dev-python/python-dotenv/python-dotenv-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Manage .env files"
+HOMEPAGE="
+ https://github.com/theskumar/python-dotenv/
+ https://pypi.org/project/python-dotenv/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/click-5[${PYTHON_USEDEP}]
+ >=dev-python/sh-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/ipython[${PYTHON_USEDEP}]
+ ' python3_{10,11})
+ )
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+python_install() {
+ distutils-r1_python_install
+ ln -s dotenv "${D}$(python_get_scriptdir)"/python-dotenv || die
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # Avoid collision with dev-ruby/dotenv (bug #798648)
+ mv "${ED}"/usr/bin/{,python-}dotenv || die
+}