summaryrefslogtreecommitdiff
path: root/dev-python/python-docs/python-docs-3.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-python/python-docs/python-docs-3.7.0.ebuild
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-python/python-docs/python-docs-3.7.0.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-3.7.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-3.7.0.ebuild b/dev-python/python-docs/python-docs-3.7.0.ebuild
new file mode 100644
index 000000000000..065d7091d1dc
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.7.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}" || die
+ doenvd "60python-docs-${SLOT}"
+}