summaryrefslogtreecommitdiff
path: root/dev-python/python-debian
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/python-debian
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest2
-rw-r--r--dev-python/python-debian/python-debian-0.1.39.ebuild11
2 files changed, 6 insertions, 7 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
index c6470900e4c7..5d15b87e8194 100644
--- a/dev-python/python-debian/Manifest
+++ b/dev-python/python-debian/Manifest
@@ -1,4 +1,4 @@
AUX 0.1.39-disable-apt-pkg.patch 6815 BLAKE2B 443dfc1c0c60d47709f31f1d3f0196c703490a9491e8de61ea9a093a80e5d87fdf17e1b1ebd5b885a1e2c0104c243aef2dee4a8f1902b9b5f747ec1b797c93a9 SHA512 ffb0659feaaa1538bc7a40b896e6bfc53f51032aadf0c0642a3609d10a13a043c2bbea97e43fddd315fe5aa174a94c9fb3fbb9832bfebdf2acebd7a30cea3717
DIST python-debian_0.1.39.tar.xz 319020 BLAKE2B de38ddc6e4878404f9685a264e1198e513cb57f7bfea064e4512ee00049d007b6007ee7fea42e18bd2f12dc8132582fbea2235694b5f908c9ae5cbc830cfe98a SHA512 de29ef224a17b149dde8cf6bb4b9fe77aa1fdfc040463163fb97f7e4ed283f16af43422e26c352183fd74e9e0ff6b41a91ee18c63b5534d5c9de2ef663c8f4df
-EBUILD python-debian-0.1.39.ebuild 895 BLAKE2B fb7c8ffa21edafb840b8087ccde9c91a62571ddd65aa12c13db24d26c3ed643c0365ed0fc04458ecdd2b13e2f433c7cb10387f80cde652a94410f5e16250748a SHA512 ae69f7a467682520a865e1ab67a28a7b60b3669e9ed0b67dda4e3f05f8f78f3d687fa9906b393f849fcbb0417cebab9e6e00b785358b932c716e66e47acb64d5
+EBUILD python-debian-0.1.39.ebuild 766 BLAKE2B 8c0fe936e3786037eccfcf50080d232fafb2141800ed726e05ff52f09279ed653b723702b044a57d7f1a49462c0b81e81bd0260cf7155fd18d0fbbd035a4ccd5 SHA512 b6e3e18338d5f5891cfe104654932d551aec3fd1207d776e329562d18068b3ca72f1f9c239c82efbcd0e6769f7cab8b1adf5ebf74889926835d30c4e07b17f7f
MISC metadata.xml 447 BLAKE2B 3a50201209da0fe9153963a3c84fbfcd72eb2a9065c6ef2dc6d21436d12269d6188e7b5c3bf88688e91bdde0e8f33a1adf9d11e084cca4ef796435655ec32765 SHA512 54c833fe01cfe54156de60c39d5cab5f9324074ddb2efd0c8294cc55d3ef599c0c65e911855c93bbb4f42cdec489dc5b337b0a0a53113816110321ea291538e1
diff --git a/dev-python/python-debian/python-debian-0.1.39.ebuild b/dev-python/python-debian/python-debian-0.1.39.ebuild
index 372a80438504..63a9d4c02307 100644
--- a/dev-python/python-debian/python-debian-0.1.39.ebuild
+++ b/dev-python/python-debian/python-debian-0.1.39.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -13,19 +13,18 @@ SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
LICENSE="GPL-2 GPL-3"
SLOT="0"
KEYWORDS="amd64 arm x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
-BDEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? ( app-arch/dpkg )
"
+distutils_enable_tests unittest
+
PATCHES=( "${FILESDIR}/0.1.39-disable-apt-pkg.patch" )
python_compile_all() {
@@ -33,5 +32,5 @@ python_compile_all() {
}
python_test() {
- ${EPYTHON} -m unittest discover --verbose lib || die "Testing failed with ${EPYTHON}"
+ eunittest lib
}