summaryrefslogtreecommitdiff
path: root/dev-python/python-debian
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/python-debian
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest2
-rw-r--r--dev-python/python-debian/python-debian-0.1.43.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
index b30986ddd7f8..b2587aa288e3 100644
--- a/dev-python/python-debian/Manifest
+++ b/dev-python/python-debian/Manifest
@@ -1,3 +1,5 @@
DIST python-debian_0.1.42.tar.xz 173928 BLAKE2B 615be084cba8ff11eaaefc1b40335b73a16604b864600dbeb717ba65ee94f1d3a62f845a59c3db5b915346de4211fdde811593db989b143f4d60e7b425b98d2d SHA512 923831077d0a42dafd22277579e714af33b99612e5282f5d95bc884b2faec05321f8caaad20b72b25ce88d8c2449a6a23913c5377ed0bdc30d4ef87e39341ff7
+DIST python-debian_0.1.43.tar.xz 175832 BLAKE2B 2b43da25392c844a3c8fa8e159695ef4c871c6620be88d286abde31b9285e3f005e3c20997617d24014fe94a1a3c446c8721f8d92c35018ac308da8703788bcd SHA512 510dd37ef65be2ee0f9c4c4c15010b94fc7c05c621de2cb25fee4f6e741f51dff2e4cdc333313bac8269bfa621533217b3f72ecbd8b0b6368aa52c54e5237bb6
EBUILD python-debian-0.1.42.ebuild 876 BLAKE2B 4fc093bbf6488fa96525349b996abc239be001cc242cf736c3ed1f58d26387f60ca782e2f71f0c2bc5135b7fb3f52914522aa3b983a75578b059e3820fbcb531 SHA512 dcfb6c1a233c5719231ddcd0660a586f6c8f7f10a5e86bc28c951e954df7cb7f190aa4246aebab8dc56fc27d7a9ed41b41c4aa49b659b10433f5b77eaceb81de
+EBUILD python-debian-0.1.43.ebuild 913 BLAKE2B df332f56c241c64e270d6cb8476aada6c4f6f1f2617a6bcc3417a875a03862e737d86ce109db7d06ae29935d06a51417615c28a6d41d0213f0a63e21dc58e34e SHA512 41298ba309f7268a61927c0378c15316d16029c3d0db0aac65fb77f72f54b9461b15b38b6e5b8b697dabe25a355cfd1c835e54523abaa2c8510d69122b1ed255
MISC metadata.xml 448 BLAKE2B bccb39bdfb24e81bc05028fc92033468f5256be096cb409b4413f69444d59d3d9a3469047337a7fec79ac707ddf4d269b44b20c725f7fc4935bd10335e1f9374 SHA512 8e3fb6ca4bf305e23a51ff56cf84648aad1e96d36aa7a4fb138f7136ea77a6a76a8985557ecb1c9da962479c8c9e36c253655d6e6602c1833f2a2230b44540aa
diff --git a/dev-python/python-debian/python-debian-0.1.43.ebuild b/dev-python/python-debian/python-debian-0.1.43.ebuild
new file mode 100644
index 000000000000..ef7feef28718
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.43.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="https://salsa.debian.org/python-debian-team/python-debian"
+SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? ( app-arch/dpkg )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # See debian/rules.
+ sed -e "s/__CHANGELOG_VERSION__/${PV}/" lib/debian/_version.py.in > lib/debian/_version.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # See debian/rules.
+ "${EPYTHON}" lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ eunittest lib
+}