summaryrefslogtreecommitdiff
path: root/dev-python/python-ddp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-ddp
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-ddp')
-rw-r--r--dev-python/python-ddp/Manifest4
-rw-r--r--dev-python/python-ddp/metadata.xml17
-rw-r--r--dev-python/python-ddp/python-ddp-0.1.5.ebuild24
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/python-ddp/Manifest b/dev-python/python-ddp/Manifest
new file mode 100644
index 000000000000..8635a7a521ce
--- /dev/null
+++ b/dev-python/python-ddp/Manifest
@@ -0,0 +1,4 @@
+DIST python-ddp-0.1.5.tar.gz 6032 SHA256 1420f23e89c4ac378ba2f4b311ddcd032e0f0af4f79f8b0829cfad972d2e588f SHA512 25200624a4a2145d3189646c00ba023f1e55010ca1756eb36505f85b6faa24da8a505f2784b8c445232ed471d5d402b4c0f487b3c9460c948295cda74faa7fbb WHIRLPOOL a3c4f3a1570fd4e9c4e30efd11954d6d927bf22beaa47adb4772b43e4bf8f88e42079a263b3ce72647628308bf52e19681cb390041a14cfb9529f74a2cef679c
+EBUILD python-ddp-0.1.5.ebuild 557 SHA256 593d840780e5d62483500ce1cd644273f171567c7b7518820f0b7b78e27fc899 SHA512 a0a095948ef53af441226ee80a9845c8ea5bac5bb663f6df40758589ffcf3c8d8ccd0fef301f37fc1fe801c5e33520f17c7905edd81f9e9eaf3c44b2fee89e86 WHIRLPOOL 399c82d1c461b6474241090ccfe45140ef0f5ceb9c39f1f5f4bb75d8e8801caf6a2e8269c1010e698fe5bfee551fa26c393191cc3bbc7d25636e5cb9ff3fb6a8
+MISC ChangeLog 1298 SHA256 91ef6d9bd18cb89b3271842681fd281c676381145e5b5b9b320a6f25c9029fa0 SHA512 b42137bc4d1a2934787b97c6013f2319ad51c071d3c968780f2061e0add1fa526fc642608808cde9e8451f87c16163c2d9221a744062fe6b27ed83fcf30238a4 WHIRLPOOL f822bcc78c5e1c573936afee939dfdf3a37c64ca5028022ae62b3a5884e3e56b0563dd808caf45228af01ff810e888b3edf1ea63d380fa35816fd9d3591b671f
+MISC metadata.xml 578 SHA256 226027d556bb5529dc32aec2a8fe54f80cd8234e75eab62a75659f1a1616e2e8 SHA512 1e66e8908ef5f4fced36e2d6386cf0f53fa16bbddd0bc08891f8d6cdfa27e3f9546b2fa8015289b8a0a254dcf0b192269fc4c212df1187dba5729249ba5a8c45 WHIRLPOOL bf995d1a04261e7a52861d792957a619682c18027155c2800307cd2d124dec021380b5d3704e93815194e97d3a235662b7f2405eb5a69f8e388bd7c673411164
diff --git a/dev-python/python-ddp/metadata.xml b/dev-python/python-ddp/metadata.xml
new file mode 100644
index 000000000000..1dd8b0430963
--- /dev/null
+++ b/dev-python/python-ddp/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-ddp</remote-id>
+ <remote-id type="github">hharnisc/python-ddp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-ddp/python-ddp-0.1.5.ebuild b/dev-python/python-ddp/python-ddp-0.1.5.ebuild
new file mode 100644
index 000000000000..fe3a30a75405
--- /dev/null
+++ b/dev-python/python-ddp/python-ddp-0.1.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="An event driven ddp client"
+HOMEPAGE="https://pypi.python.org/pypi/python-ddp https://github.com/hharnisc/python-ddp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-python/pyee[${PYTHON_USEDEP}]
+ dev-python/ws4py[${PYTHON_USEDEP}]
+ dev-python/meteor-ejson[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"