summaryrefslogtreecommitdiff
path: root/dev-python/python-ctags3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-04 09:34:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-04 09:34:05 +0100
commit13b130894803eda558b74353eda3bf7504615b38 (patch)
treeeb6788b9eeef843120928d0df4cd2b5667aeccb3 /dev-python/python-ctags3
parent5c9bbe083a12cfb9666fed4abe5bce219ff2f019 (diff)
gentoo auto-resync : 04:06:2023 - 09:34:05
Diffstat (limited to 'dev-python/python-ctags3')
-rw-r--r--dev-python/python-ctags3/Manifest5
-rw-r--r--dev-python/python-ctags3/metadata.xml13
-rw-r--r--dev-python/python-ctags3/python-ctags3-1.5.0-r1.ebuild40
-rw-r--r--dev-python/python-ctags3/python-ctags3-1.6.0.ebuild47
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/python-ctags3/Manifest b/dev-python/python-ctags3/Manifest
new file mode 100644
index 000000000000..5e92c9e78854
--- /dev/null
+++ b/dev-python/python-ctags3/Manifest
@@ -0,0 +1,5 @@
+DIST python-ctags3-1.5.0.gh.tar.gz 63921 BLAKE2B 1d25e7bafbdf157f1051321058b39fc9347bc479a61fae637bd11ef8540a3c67e2abd101493668977f05e464a8203b8c518fd1f4433defe5cec9939a200438b2 SHA512 414774c865af51e54c53f66dc7b3cfb5a03b64ea4eb94325658c158542615dfffdd1a5933d9ae03cedf1dbac30e1810d5914fbc3d6ab41e5f708c5d3000d161e
+DIST python-ctags3-1.6.0.gh.tar.gz 70311 BLAKE2B f286aad922f8220d5f0b42f2919425d836bd27e9b2a85739333295d6e681172b20d33d010821c881583a4bed29d103939cf4b7e1d67190ba52cf1e0a1ca75290 SHA512 38df28c1055b2240e5da7699a7c72bab85908c7b1a1b4db83f19350541fe49d8499a9b7400ad14c77166b459fbb30f6b2c22d65685ac5f392ececa3eeecb6f41
+EBUILD python-ctags3-1.5.0-r1.ebuild 1050 BLAKE2B 337ad05c2452fe9e16f83d0c275cf8f0fea34eb5b67d8edc1f837b619b6b8f526b14f03a7cca1378bc056dd76040a7318fc5aa142ccf3ae69543822b6a485630 SHA512 3e4abfc0adf9a36dc70a7294282d49f1ea3c4623c7068538c6ebcf6325b70a9ae140ac125c505c95334769cfb22d01d12826207ff5641128d72983a03e9932b4
+EBUILD python-ctags3-1.6.0.ebuild 1078 BLAKE2B 9ef570194cb8318d98acd6d939de121af8a1d75630eec276c716e157647003c3eb8d201768458167723c7d50e018b76ab5cb84dabda47e3e4b1c58926df1c47b SHA512 ec2bfaf82071a409edd85aafecee67fbaf1e1f6201e637fe6399de606951e77a308b8cb35640c03eebf63012a797c66022b86966f8b914462876c6e7930ac6e0
+MISC metadata.xml 468 BLAKE2B 7a89bc7a950e780ed4093c77ba31c18dd0e92e6e661c20012e0c97e1e00176c9116b830b1f80359a71ab51b6e22614b820d27b449dd7c16f884d85f1adbe83ad SHA512 39956be9e9e61a5fbc02340d5fadd1044784fe73d39523b500bc74e4943d57f6581bfdc366f763eeaf5851cd5d34e348856d3c92450ca6c31691eb9f36c56154
diff --git a/dev-python/python-ctags3/metadata.xml b/dev-python/python-ctags3/metadata.xml
new file mode 100644
index 000000000000..69a96d84a4dd
--- /dev/null
+++ b/dev-python/python-ctags3/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-ctags3</remote-id>
+ <remote-id type="github">universal-ctags/python-ctags3</remote-id>
+ <bugs-to>https://github.com/universal-ctags/python-ctags3/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-ctags3/python-ctags3-1.5.0-r1.ebuild b/dev-python/python-ctags3/python-ctags3-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..fea99da7b0d2
--- /dev/null
+++ b/dev-python/python-ctags3/python-ctags3-1.5.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="python-ctags3-${PV}"
+DESCRIPTION="Exuberant Ctags indexing python bindings"
+HOMEPAGE="https://github.com/universal-ctags/python-ctags3"
+# PyPI tarballs don't contain pyx files
+SRC_URI="https://github.com/universal-ctags/python-ctags3/archive/${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-util/ctags:="
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # We currently need to let Cython regenerate this file to make Python 3.11
+ # support work
+ rm src/_readtags.c || die
+ cython -3 src/_readtags.pyx || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # To prevent pytest from importing it and failing with:
+ # ModuleNotFoundError: No module named 'ctags._readtags'
+ rm -rf src/ctags || die
+ epytest
+}
diff --git a/dev-python/python-ctags3/python-ctags3-1.6.0.ebuild b/dev-python/python-ctags3/python-ctags3-1.6.0.ebuild
new file mode 100644
index 000000000000..89f53b3750e2
--- /dev/null
+++ b/dev-python/python-ctags3/python-ctags3-1.6.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="python-ctags3-${PV}"
+DESCRIPTION="Exuberant Ctags indexing python bindings"
+HOMEPAGE="https://github.com/universal-ctags/python-ctags3"
+# PyPI tarballs don't contain pyx files
+SRC_URI="https://github.com/universal-ctags/python-ctags3/archive/${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-util/ctags:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # We currently need to let Cython regenerate this file to make Python 3.11
+ # support work
+ rm src/_readtags.c || die
+ cython -3 src/_readtags.pyx || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # To prevent pytest from importing it and failing with:
+ # ModuleNotFoundError: No module named 'ctags._readtags'
+ rm -rf src/ctags || die
+ epytest
+}