summaryrefslogtreecommitdiff
path: root/dev-python/python-cstruct/python-cstruct-3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-24 21:52:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-24 21:52:37 +0100
commit7ae4e1d32a98b596d483a19ed94a21b560eb595d (patch)
tree1c68a1258f5017984a7878d5e913d95d72544f59 /dev-python/python-cstruct/python-cstruct-3.3.ebuild
parent145ac95c683ecda55a9b2cafc84dced2e9c29e03 (diff)
gentoo auto-resync : 24:10:2022 - 21:52:37
Diffstat (limited to 'dev-python/python-cstruct/python-cstruct-3.3.ebuild')
-rw-r--r--dev-python/python-cstruct/python-cstruct-3.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-cstruct/python-cstruct-3.3.ebuild b/dev-python/python-cstruct/python-cstruct-3.3.ebuild
new file mode 100644
index 000000000000..7b8d01c50942
--- /dev/null
+++ b/dev-python/python-cstruct/python-cstruct-3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="C-style structs for Python"
+HOMEPAGE="https://github.com/andreax79/python-cstruct
+ https://pypi.org/project/cstruct/"
+SRC_URI="
+ https://github.com/andreax79/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ sed -e "/find_packages(/s@exclude=\[@&'tests', @" -i setup.py || die
+}