summaryrefslogtreecommitdiff
path: root/dev-python/python-cinderclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
commitdd762ff83c330186ee2ede002e08b2f780cddd51 (patch)
tree63198edcc3ad5df8e2566c28ff9bd8af50cc2174 /dev-python/python-cinderclient
parent51af5f0eb4cddbe6aa7953717873691d77aae9ff (diff)
gentoo resync : 14.07.2019
Diffstat (limited to 'dev-python/python-cinderclient')
-rw-r--r--dev-python/python-cinderclient/Manifest2
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-4.2.1.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/Manifest b/dev-python/python-cinderclient/Manifest
index ee80ba0a3827..a24470299dee 100644
--- a/dev-python/python-cinderclient/Manifest
+++ b/dev-python/python-cinderclient/Manifest
@@ -1,5 +1,7 @@
DIST python-cinderclient-4.1.0.tar.gz 288464 BLAKE2B 492baefef164e74eca662cbde31b77ae751730420782b9926d265548d064cef08e993279482c566f1c810a62f6cda657e59680d511e5633a7c17be8dbc6fe7c1 SHA512 e895e90dd12802c5991bd05c825b712b30bded38a5dd0dc8d845949cc7e76440959a426cb680447496cccdbb0d5aa31f3b982838a91c7b36e8e31bbaa3fb7b7a
DIST python-cinderclient-4.2.0.tar.gz 284743 BLAKE2B 2306cbc80cf47086aa0dd545f73adc54cbc6fe162f972f2c5d610f26ecccbd38b0b6f028b8e1a548b63d6dcdd32b26bf3dfdcd8e9e360db0325b024e3bbe7bb0 SHA512 d61a10719fbcffd6562c9b7802ac26e317878f52f5db8a704ef57c8ed9b883eaa3a961c2f29df5746befb82b1a29714fa75082df2deebc305115e103e49eee91
+DIST python-cinderclient-4.2.1.tar.gz 287696 BLAKE2B b79068acfeafd9e8ab85035fcda1cceaacc68d3a847b4d070fcb16efdf103ad362c21196afc0ea23eba6a9110f5e96d8de8e2446889740c9abccd912a972358d SHA512 e72af1163bbd882354aea3b7ecdc36cad0899589430e31006f9b1f5f1d00866c9c0de631d2a94b83b3dc358039069adefef54231ecb191ad167339ca3a37a588
EBUILD python-cinderclient-4.1.0.ebuild 1117 BLAKE2B 94787b748dacc36053a90285b42b3a7f3b2c09f7f71d931eb8015dd99db406bf025a9d29141096cdaa8929eba55fafb724989ba948a83ae5fd243948952a67a3 SHA512 edce03675cbf2266dc7ea7136d5951a469b1c0ecfe651fef4b8eba7df96203abe190fa2399fb5c9ef07505e87e14b6591c69ab0f6f00bbf81d962b333496cc60
EBUILD python-cinderclient-4.2.0.ebuild 1117 BLAKE2B 94787b748dacc36053a90285b42b3a7f3b2c09f7f71d931eb8015dd99db406bf025a9d29141096cdaa8929eba55fafb724989ba948a83ae5fd243948952a67a3 SHA512 edce03675cbf2266dc7ea7136d5951a469b1c0ecfe651fef4b8eba7df96203abe190fa2399fb5c9ef07505e87e14b6591c69ab0f6f00bbf81d962b333496cc60
+EBUILD python-cinderclient-4.2.1.ebuild 1119 BLAKE2B 09eff65811760148a77bd871ab289e8d37bffa8d0e975f280463619d25ac9a4ad9f1b9ba804f0b6be4beb2ecb90c5c9362c64439f6431ac460789c6d3bdfcd2d SHA512 4a8c307edac5c09623c4db0f6e32c980a8120ca1221f4a5ae035a1d45bf25482b74a3895c46a4cbbfa61693a804935a0ceb584947dee3c82b5392a2d31cfcec3
MISC metadata.xml 625 BLAKE2B a9011769fe7ab23b5b00cdfe6e209e92186abffd4a32e6b21e2741ea8b58848b3aee384d301c3bfeeaaea3632becc5db22afcd8d6b149d17db34198a89e86ca6 SHA512 397ec06d3fb289940f654600dd452f5450ab6a87b4584f5486196a5467b7b5b9251c241c28b92a17b92da9d0a094b1a4d4ec303fe8eb3087c50a560f423bf92a
diff --git a/dev-python/python-cinderclient/python-cinderclient-4.2.1.ebuild b/dev-python/python-cinderclient/python-cinderclient-4.2.1.ebuild
new file mode 100644
index 000000000000..c89d38330451
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-4.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}