summaryrefslogtreecommitdiff
path: root/dev-python/python-cinderclient/python-cinderclient-9.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-16 21:37:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-16 21:37:19 +0000
commitcdda1ab7293bc67061befd2b34a4ed761e887042 (patch)
treede8e76bfa9ffd50c53fb3ad32c722257c030136b /dev-python/python-cinderclient/python-cinderclient-9.2.0.ebuild
parent39fcd539b9eeb7df75bccad136265b5f001d1a3c (diff)
gentoo auto-resync : 16:12:2022 - 21:37:19
Diffstat (limited to 'dev-python/python-cinderclient/python-cinderclient-9.2.0.ebuild')
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-9.2.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/python-cinderclient-9.2.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-9.2.0.ebuild
new file mode 100644
index 000000000000..39b6c7ad8c83
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-9.2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-5.0.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pbr-5.5.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.3.0[${PYTHON_USEDEP}]
+"
+# Tests fail with dev-python/prettytable-3.4.0
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/oslo-serialization[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ <dev-python/prettytable-3.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-9.1.0-fix-py3.11-argparse.patch"
+ "${FILESDIR}/${PN}-9.1.0-fix-py3.11-crashes.patch"
+)
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b cinderclient/tests/unit
+}