summaryrefslogtreecommitdiff
path: root/dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild')
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild b/dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild
new file mode 100644
index 000000000000..05c40aa71118
--- /dev/null
+++ b/dev-python/python-bugzilla/python-bugzilla-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
+HOMEPAGE="https://github.com/python-bugzilla/python-bugzilla"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ || ( dev-python/python-magic[${PYTHON_USEDEP}] sys-apps/file[python,${PYTHON_USEDEP}] )
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage
+ dev-python/pep8
+ )
+"
+
+python_test() {
+ "${EPYTHON}" ./setup.py test
+}