summaryrefslogtreecommitdiff
path: root/dev-python/python-box/python-box-7.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-22 08:27:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-22 08:27:35 +0000
commit20ed81714fa97f5845db16a3c142b3b44d820bc4 (patch)
tree76683b348b31d271f9afcd3dbc414afb92dc3ba0 /dev-python/python-box/python-box-7.0.1.ebuild
parent1b013d9d13c304bf66a4a6c16d272d25bc480b83 (diff)
gentoo auto-resync : 22:02:2023 - 08:27:35
Diffstat (limited to 'dev-python/python-box/python-box-7.0.1.ebuild')
-rw-r--r--dev-python/python-box/python-box-7.0.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-box/python-box-7.0.1.ebuild b/dev-python/python-box/python-box-7.0.1.ebuild
new file mode 100644
index 000000000000..cb140b6ae872
--- /dev/null
+++ b/dev-python/python-box/python-box-7.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=Box-${PV}
+DESCRIPTION="Python dictionaries with advanced dot notation access"
+HOMEPAGE="
+ https://github.com/cdgriffith/Box/
+ https://pypi.org/project/python-box/
+"
+SRC_URI="
+ https://github.com/cdgriffith/Box/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest