summaryrefslogtreecommitdiff
path: root/dev-python/pytest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/pytest
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/Manifest4
-rw-r--r--dev-python/pytest/files/pytest-6.2.5-py310.patch81
-rw-r--r--dev-python/pytest/pytest-6.2.5-r2.ebuild33
-rw-r--r--dev-python/pytest/pytest-6.2.5-r3.ebuild80
4 files changed, 193 insertions, 5 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index bffa24125919..ed7d6011d734 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -1,3 +1,5 @@
+AUX pytest-6.2.5-py310.patch 2866 BLAKE2B d7ec82ec4a9ed554021f915ffc4a37e1a19b4e404de0c77650c1b85812196b8254a09be6790cde971df55b7bd54036a9b501e6901e0e56f7f12adb20d053174c SHA512 7c25682829c13651f35e5364ee8d1393ccf338e295a86f6379ad7bf83c38a5399bfa3d48d57813ca520770f9851c1aa00a8d891709fd2c9ec53c21f04bb13803
DIST pytest-6.2.5.tar.gz 1118720 BLAKE2B 9dfc87279617be58353566009325f929e6fa53d54fd4c665a75f3b359ab5415972d745a680eb85ab21ca9eaec84450bc1decd50566b0ccdf90d7551f3d03ee70 SHA512 7624563a9d967da4cbf82cfff90bae8c0cca07b32e291dc7c5efa787725ed1a255edd066bf0d5fbd89b8cbed8cf5b619fe7c7017f44a7f8a014e3310c06bdbf9
-EBUILD pytest-6.2.5-r2.ebuild 1456 BLAKE2B f2cc845bffc5ac26d1bcb985a5e5af6db12b70e6cb04ef79d86783fccadfb005dd67b22d5122939cb8f2465b36f88f4de9ceb9f0fe38183bdf2947cb99128bc8 SHA512 1a739dd169ccbb693f61f5ea8c3b2f4294b0055c4210d53600e9abaeaa1f90658dd3c13ebb6ff7dcd476e6b4f40420127bf2f508de31c554761bb41997c8e6d5
+EBUILD pytest-6.2.5-r2.ebuild 2498 BLAKE2B 87b8669a250a6cd5b0bca5f21be57f335a8498d300c6872e14132fb91f260b38b78255618af1bebe0a9468d6b97e9458a0d38d7d4c6055f65aa46f5200fee7b1 SHA512 b3d1141704e3bfab0873f111bdcdd1eb10e5883f25f86b2689e96f13aee71bd84c4d61b4fda3a9abf9a4eac95e8dff8d3827368e0a146c66832b86a4994ace89
+EBUILD pytest-6.2.5-r3.ebuild 2602 BLAKE2B 8b77b3622e469c9b4fe16ba170fe3bae4bc12b408d593276e1649fd3464f954f891001371906130baf72ddcbf7b79b4d0603f52080b8668df1d814a4bd2a8adb SHA512 5acac61f2a1c951a90df9161779afe9de89e81e169a8b7bc8b24825313a97563f8b7efab409fa77e138fdf54c5b7dce3349bf54d0fdb86b8a6d6a5fe8a55f493
MISC metadata.xml 391 BLAKE2B 48d31ecb4c8b171ee4e84a58399211368ddc00dfb5dbe0999f96e03d744294cd4fd5263e90600c93d1f13c7da21052faef84b6d0d56709f3559e37b3392ca31d SHA512 6e9caa57eda23995d21df6f52c52d5868e1ff56abb6c1351ffc0fe14b771639473481a2630e659caaff83f0255379aa2d012175af52a0de41221b27d3ab2f425
diff --git a/dev-python/pytest/files/pytest-6.2.5-py310.patch b/dev-python/pytest/files/pytest-6.2.5-py310.patch
new file mode 100644
index 000000000000..89ca41954273
--- /dev/null
+++ b/dev-python/pytest/files/pytest-6.2.5-py310.patch
@@ -0,0 +1,81 @@
+From 5082686349185ef35f64d1a998a3062ee5a48771 Mon Sep 17 00:00:00 2001
+From: Ran Benita <ran@unusedvar.com>
+Date: Thu, 13 May 2021 17:27:43 +0300
+Subject: [PATCH 1/2] Merge pull request #8664 from
+ hroncok/test_unittest-ignore_DeprecationWarning-from-twisted
+
+Ignore DeprecationWarnings in test_trial_error
+
+(cherry picked from commit 850a8447792f89c7d38c72b2f542536655ab0354)
+---
+ testing/test_unittest.py | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/testing/test_unittest.py b/testing/test_unittest.py
+index 8b00cb826..de8fc5c55 100644
+--- a/testing/test_unittest.py
++++ b/testing/test_unittest.py
+@@ -533,7 +533,9 @@ class TestTrialUnittest:
+ # will crash both at test time and at teardown
+ """
+ )
+- result = testdir.runpytest("-vv", "-oconsole_output_style=classic")
++ result = testdir.runpytest(
++ "-vv", "-oconsole_output_style=classic", "-W", "ignore::DeprecationWarning"
++ )
+ result.stdout.fnmatch_lines(
+ [
+ "test_trial_error.py::TC::test_four FAILED",
+--
+2.35.0
+
+From 932792c22a300fc7794f966851df2b996f4a79bc Mon Sep 17 00:00:00 2001
+From: Bruno Oliveira <nicoddemus@gmail.com>
+Date: Thu, 16 Dec 2021 10:37:52 -0300
+Subject: [PATCH 2/2] Merge pull request #9417 from
+ nicoddemus/fix-py3.10.1-9413
+
+(cherry picked from commit 47df71d23ff13bd083b21ffcf839bd11169b42fc)
+---
+ .github/workflows/main.yml | 4 ++--
+ testing/test_skipping.py | 2 --
+ 2 files changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
+index 5a9435357..a8a6406c6 100644
+--- a/.github/workflows/main.yml
++++ b/.github/workflows/main.yml
+@@ -75,7 +75,7 @@ jobs:
+ os: windows-latest
+ tox_env: "py39-xdist"
+ - name: "windows-py310"
+- python: "3.10-dev"
++ python: "3.10.1"
+ os: windows-latest
+ tox_env: "py310-xdist"
+
+@@ -105,7 +105,7 @@ jobs:
+ os: ubuntu-latest
+ tox_env: "py39-xdist"
+ - name: "ubuntu-py310"
+- python: "3.10-dev"
++ python: "3.10.1"
+ os: ubuntu-latest
+ tox_env: "py310-xdist"
+ - name: "ubuntu-pypy3"
+diff --git a/testing/test_skipping.py b/testing/test_skipping.py
+index 3cb8bdff2..487793645 100644
+--- a/testing/test_skipping.py
++++ b/testing/test_skipping.py
+@@ -1126,8 +1126,6 @@ def test_errors_in_xfail_skip_expressions(pytester: Pytester) -> None:
+ pypy_version_info = getattr(sys, "pypy_version_info", None)
+ if pypy_version_info is not None and pypy_version_info < (6,):
+ markline = markline[5:]
+- elif sys.version_info[:2] >= (3, 10):
+- markline = markline[11:]
+ elif sys.version_info >= (3, 8) or hasattr(sys, "pypy_version_info"):
+ markline = markline[4:]
+
+--
+2.35.0
+
diff --git a/dev-python/pytest/pytest-6.2.5-r2.ebuild b/dev-python/pytest/pytest-6.2.5-r2.ebuild
index c3a65979f46f..6679e63a6906 100644
--- a/dev-python/pytest/pytest-6.2.5-r2.ebuild
+++ b/dev-python/pytest/pytest-6.2.5-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
+inherit distutils-r1 multiprocessing
DESCRIPTION="Simple powerful testing with Python"
HOMEPAGE="https://pytest.org/"
@@ -33,10 +33,16 @@ BDEPEND="
>=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/xmlschema[${PYTHON_USEDEP}]
)"
+PATCHES=(
+ # backport fixes for py3.10 test regressions
+ "${FILESDIR}"/${P}-py310.patch
+)
+
src_test() {
# workaround new readline defaults
echo "set enable-bracketed-paste off" > "${T}"/inputrc || die
@@ -47,6 +53,25 @@ src_test() {
python_test() {
distutils_install_for_testing --via-root
- "${EPYTHON}" -m pytest -vv --lsof -rfsxX -p no:pkgcore -p no:flaky ||
- die "Tests failed with ${EPYTHON}"
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ local EPYTEST_DESELECT=(
+ # broken by epytest args
+ testing/test_warnings.py::test_works_with_filterwarnings
+
+ # tend to be broken by random pytest plugins
+ # (these tests patch PYTEST_DISABLE_PLUGIN_AUTOLOAD out)
+ testing/test_helpconfig.py::test_version_less_verbose
+ testing/test_helpconfig.py::test_version_verbose
+ testing/test_junitxml.py::test_random_report_log_xdist
+ testing/test_junitxml.py::test_runs_twice_xdist
+ testing/test_terminal.py::TestProgressOutputStyle::test_xdist_normal
+ testing/test_terminal.py::TestProgressOutputStyle::test_xdist_normal_count
+ testing/test_terminal.py::TestProgressOutputStyle::test_xdist_verbose
+ testing/test_terminal.py::TestProgressWithTeardown::test_xdist_normal
+ testing/test_terminal.py::TestTerminalFunctional::test_header_trailer_info
+ testing/test_terminal.py::TestTerminalFunctional::test_no_header_trailer_info
+ )
+
+ epytest -p xdist -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
}
diff --git a/dev-python/pytest/pytest-6.2.5-r3.ebuild b/dev-python/pytest/pytest-6.2.5-r3.ebuild
new file mode 100644
index 000000000000..888dfd1c2010
--- /dev/null
+++ b/dev-python/pytest/pytest-6.2.5-r3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="https://pytest.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ dev-python/iniconfig[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ >=dev-python/py-1.8.2[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-3.4[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ # backport fixes for py3.10 test regressions
+ "${FILESDIR}"/${P}-py310.patch
+)
+
+src_test() {
+ # workaround new readline defaults
+ echo "set enable-bracketed-paste off" > "${T}"/inputrc || die
+ local -x INPUTRC="${T}"/inputrc
+ distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ local EPYTEST_DESELECT=(
+ # broken by epytest args
+ testing/test_warnings.py::test_works_with_filterwarnings
+
+ # tend to be broken by random pytest plugins
+ # (these tests patch PYTEST_DISABLE_PLUGIN_AUTOLOAD out)
+ testing/test_helpconfig.py::test_version_less_verbose
+ testing/test_helpconfig.py::test_version_verbose
+ testing/test_junitxml.py::test_random_report_log_xdist
+ testing/test_junitxml.py::test_runs_twice_xdist
+ testing/test_terminal.py::TestProgressOutputStyle::test_xdist_normal
+ testing/test_terminal.py::TestProgressOutputStyle::test_xdist_normal_count
+ testing/test_terminal.py::TestProgressOutputStyle::test_xdist_verbose
+ testing/test_terminal.py::TestProgressWithTeardown::test_xdist_normal
+ testing/test_terminal.py::TestTerminalFunctional::test_header_trailer_info
+ testing/test_terminal.py::TestTerminalFunctional::test_no_header_trailer_info
+
+ # unstable with xdist
+ testing/test_terminal.py::TestTerminalFunctional::test_verbose_reporting_xdist
+ )
+
+ epytest -p xdist -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}