summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild')
-rw-r--r--dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild
index af48d69b6055..e6d752d53f87 100644
--- a/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild
+++ b/dev-python/pytest-xvfb/pytest-xvfb-2.0.0.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/The-Compiler/pytest-xvfb/archive/v${PV}.tar.gz -> ${
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
DEPEND="
>=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
@@ -24,6 +24,10 @@ DEPEND="
distutils_enable_tests pytest
python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests failed with ${EPYTHON}"
+ local -x PYTHONPATH="${BUILD_DIR}/install/lib"
+ esetup.py install \
+ --root="${BUILD_DIR}/install" \
+ --install-lib=lib
+
+ pytest -vv || die "Tests fail with ${EPYTHON}"
}