summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xprocess/pytest-xprocess-0.23.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-24 05:21:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-24 05:21:45 +0100
commitfcf991edcc1b310199e4e829a3706bc1c267d1db (patch)
tree50f02cb76c2666dbe78d927799c034715582c9cd /dev-python/pytest-xprocess/pytest-xprocess-0.23.0.ebuild
parent3c246ed172bd795a519ba659ba32c9e91f6bedde (diff)
gentoo auto-resync : 24:09:2023 - 05:21:45
Diffstat (limited to 'dev-python/pytest-xprocess/pytest-xprocess-0.23.0.ebuild')
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.23.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.23.0.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.23.0.ebuild
new file mode 100644
index 000000000000..adb5647ee026
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.23.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="
+ https://pypi.org/project/pytest-xprocess/
+ https://github.com/pytest-dev/pytest-xprocess/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest