summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xdist/pytest-xdist-3.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-24 09:01:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-24 09:01:51 +0100
commitbd2c7873be3178619accade4259ba907b6baca46 (patch)
treea2dd247d39fd3cd02086ae2248b0cd590397320c /dev-python/pytest-xdist/pytest-xdist-3.3.1.ebuild
parenta5d03e5440b3955446fba6d02de9f53ea4f6efc4 (diff)
gentoo auto-resync : 24:05:2023 - 09:01:50
Diffstat (limited to 'dev-python/pytest-xdist/pytest-xdist-3.3.1.ebuild')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-3.3.1.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-3.3.1.ebuild b/dev-python/pytest-xdist/pytest-xdist-3.3.1.ebuild
index cee4b9457782..57cbcf2c12f1 100644
--- a/dev-python/pytest-xdist/pytest-xdist-3.3.1.ebuild
+++ b/dev-python/pytest-xdist/pytest-xdist-3.3.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 pypi
@@ -41,5 +41,16 @@ python_test() {
# since we disabled autoloading, force loading necessary plugins
local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+ [[ ${PV} != 3.3.1 ]] && die "Recheck deselects, please!"
+ local EPYTEST_DESELECT=()
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ # failures due to warnings from pytest
+ # https://github.com/pytest-dev/pytest-xdist/issues/914
+ testing/acceptance_test.py::test_config_initialization
+ testing/acceptance_test.py::test_collection_crash
+ )
+ fi
+
epytest
}