summaryrefslogtreecommitdiff
path: root/dev-python/pytest-xdist/pytest-xdist-1.34.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/pytest-xdist/pytest-xdist-1.34.0.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/pytest-xdist/pytest-xdist-1.34.0.ebuild')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.34.0.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.34.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.34.0.ebuild
deleted file mode 100644
index d71a0fb7c1d9..000000000000
--- a/dev-python/pytest-xdist/pytest-xdist-1.34.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Distributed testing and loop-on-failing modes"
-HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# pleaes do not depend on pytest to avoid unnecessary USEDEP enforcement
-RDEPEND="
- dev-python/execnet[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-pytest4.patch
-)
-
-python_test() {
- distutils_install_for_testing
- pytest -vv testing || die "Tests failed under ${EPYTHON}"
-}