summaryrefslogtreecommitdiff
path: root/dev-python/pytest-testinfra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/pytest-testinfra
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/pytest-testinfra')
-rw-r--r--dev-python/pytest-testinfra/Manifest3
-rw-r--r--dev-python/pytest-testinfra/metadata.xml19
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild32
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
new file mode 100644
index 000000000000..bd11143e5add
--- /dev/null
+++ b/dev-python/pytest-testinfra/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-testinfra-6.3.0.tar.gz 76309 BLAKE2B 95b4a6ac5ea3c3db2afdd537209bfeb2c188ec7c7935b73e831733fbbf2540b8769d1187338b3b9c9da997cd653e800004e7199537d95530967cd73a15cb2c2e SHA512 ff0add6bdadac92f6f997a94734d69d39598bc8d1f7689a6b269e59bc886825fcf8a42968c2d34a9ad7e77ed0112bf4044afede8e0dca2bbddc76c9c5612ae92
+EBUILD pytest-testinfra-6.3.0.ebuild 880 BLAKE2B b7e518cee07ed714ab245a15890a8c4be7954bdb0166430f962c964f4d13eb8ba77671168a67c2db9dd5a9b923fba8903ae2e9a05110e854fe01bf487debb79b SHA512 af159afef4aef06f0a431cbd33c7f990be07a5a98327ab3416e8bf8058962d2d08740dd15eeb241f188c7fa9373a3c3209e819d2dadb7e9b598fc3ebde8f6d1d
+MISC metadata.xml 679 BLAKE2B 288c8de180a7dca25dd78c05228bc045480fb675a6968f24e35daf4d5b89433d040d0457d8276284019632aaf7fec979e7bf52328d08b4dd9ca1512c00add0a9 SHA512 8163d5d60f43e615e40ccaa4354713765b5a666a802b18373d06cb7d8c7f35a3b2258678f9137d0547916fa766269c5bb21c88f5b43b029e9aa24a9dddfc81f9
diff --git a/dev-python/pytest-testinfra/metadata.xml b/dev-python/pytest-testinfra/metadata.xml
new file mode 100644
index 000000000000..75d52d73c62c
--- /dev/null
+++ b/dev-python/pytest-testinfra/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ With Testinfra you can write unit tests in Python to test actual state of your servers
+ configured by management tools like Salt, Ansible, Puppet, Chef and so on.
+
+ Testinfra aims to be a Serverspec equivalent in Python.
+ </longdescription>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">pytest-dev/pytest-testinfra</remote-id>
+ <remote-id type="pypi">pytest-testinfra</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild
new file mode 100644
index 000000000000..8081571a974a
--- /dev/null
+++ b/dev-python/pytest-testinfra/pytest-testinfra-6.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+HOMEPAGE="https://github.com/pytest-dev/pytest-testinfra"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ app-admin/ansible[${PYTHON_USEDEP}]
+ app-admin/salt[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pywinrm[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog "For the list of available connection back-ends and their dependencies,"
+ elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
+}