summaryrefslogtreecommitdiff
path: root/dev-python/pytest-testinfra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-python/pytest-testinfra
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-python/pytest-testinfra')
-rw-r--r--dev-python/pytest-testinfra/Manifest2
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-6.4.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
index 14ba19ad621a..71512b020e78 100644
--- a/dev-python/pytest-testinfra/Manifest
+++ b/dev-python/pytest-testinfra/Manifest
@@ -1,3 +1,5 @@
DIST pytest-testinfra-6.3.0.tar.gz 76309 BLAKE2B 95b4a6ac5ea3c3db2afdd537209bfeb2c188ec7c7935b73e831733fbbf2540b8769d1187338b3b9c9da997cd653e800004e7199537d95530967cd73a15cb2c2e SHA512 ff0add6bdadac92f6f997a94734d69d39598bc8d1f7689a6b269e59bc886825fcf8a42968c2d34a9ad7e77ed0112bf4044afede8e0dca2bbddc76c9c5612ae92
+DIST pytest-testinfra-6.4.0.tar.gz 77516 BLAKE2B 2baf5940e8736cbe78d8017a82b3a8fdb6df95b89acccd49ecd354447b7ea88079f48211e0acea46a0d8702b67609fe6f85f730c66e781a99d8a92b52b3c99b9 SHA512 acd2c7f9daeb391815a32c972a3542c0d643a716f3cffcb66f4203435ebac789333edb91c83d2778ae8da93b676b245fd47821bca9218faa3e7b50e6764087f4
EBUILD pytest-testinfra-6.3.0.ebuild 894 BLAKE2B 3a4b17c1d33bd23982f78a4797c21e23aa2b54d33f9feba4a19a071954cc69a3143a544b60aa07c46c7a08aa2529cbabf6ef19f083357ab28928a18623ad9a4b SHA512 d58c5fd2fef7b6dea76b52c807c370bf64abdaccef78b6bc401d567d8c257f3f49f06f3d3f79dc89d47031f9da0fd879b5e97070449a2bfe9cb2675cb17b5528
+EBUILD pytest-testinfra-6.4.0.ebuild 894 BLAKE2B 1027b8c0a4d13d2db3612bd989f32414316fef63fb7a265682ae8dc5b992f886e6c2592f2645789abdf70bad3a4a12742c584645bbce974fe513b680cc5890cc SHA512 2b957be685f8e7961aa05093dfaa14783e79107becf42c6668a7b3c0d75b660bff45c05ac9f7f9c50e4c2cf068cefb8d3e4d6f78477ac5f9553ae8478c0438e0
MISC metadata.xml 679 BLAKE2B 288c8de180a7dca25dd78c05228bc045480fb675a6968f24e35daf4d5b89433d040d0457d8276284019632aaf7fec979e7bf52328d08b4dd9ca1512c00add0a9 SHA512 8163d5d60f43e615e40ccaa4354713765b5a666a802b18373d06cb7d8c7f35a3b2258678f9137d0547916fa766269c5bb21c88f5b43b029e9aa24a9dddfc81f9
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-6.4.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-6.4.0.ebuild
new file mode 100644
index 000000000000..c336646d0373
--- /dev/null
+++ b/dev-python/pytest-testinfra/pytest-testinfra-6.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+HOMEPAGE="https://github.com/pytest-dev/pytest-testinfra"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+# Ansible is called via its CLI
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ app-admin/ansible
+ app-admin/salt[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pywinrm[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog "For the list of available connection back-ends and their dependencies,"
+ elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
+}