summaryrefslogtreecommitdiff
path: root/dev-python/pytest-testinfra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/pytest-testinfra
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/pytest-testinfra')
-rw-r--r--dev-python/pytest-testinfra/Manifest2
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-6.6.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
index 99666a553726..6a72648ab15b 100644
--- a/dev-python/pytest-testinfra/Manifest
+++ b/dev-python/pytest-testinfra/Manifest
@@ -1,5 +1,7 @@
DIST pytest-testinfra-6.4.0.tar.gz 77516 BLAKE2B 2baf5940e8736cbe78d8017a82b3a8fdb6df95b89acccd49ecd354447b7ea88079f48211e0acea46a0d8702b67609fe6f85f730c66e781a99d8a92b52b3c99b9 SHA512 acd2c7f9daeb391815a32c972a3542c0d643a716f3cffcb66f4203435ebac789333edb91c83d2778ae8da93b676b245fd47821bca9218faa3e7b50e6764087f4
DIST pytest-testinfra-6.5.0.tar.gz 77177 BLAKE2B 98a8f10f7cf62f204c117d295496a7dfa4de476f5cde457af6f5bc71b22e12e9f02b4893adc6b0d1be11915ed652f628c2574fd44750c82c690e3d8326e29c4c SHA512 f7fcf8facafc0d99b06f55f4241c39b610ff7648b0049c584a75b46944b522b957c98c353f147d74bc8a72f677a179380c456b0868f9dae9af514a9c95d55b13
+DIST pytest-testinfra-6.6.0.tar.gz 78285 BLAKE2B c7583685aeb770f76e4679730599909b8fff53d1909664f55e2d35f7f5a6a96741e3aa56b81da464c2d474d1d5f646892e36a4f9b6938327cb526476536b0b6c SHA512 f78f1cd5240e157d4e2949178f29900a7b85a6065b4113b18273af3f1fef6b19c859192f59426b93eba48418bb89d163ad1d951e97d4fdfcea4394635a05140a
EBUILD pytest-testinfra-6.4.0.ebuild 894 BLAKE2B 1027b8c0a4d13d2db3612bd989f32414316fef63fb7a265682ae8dc5b992f886e6c2592f2645789abdf70bad3a4a12742c584645bbce974fe513b680cc5890cc SHA512 2b957be685f8e7961aa05093dfaa14783e79107becf42c6668a7b3c0d75b660bff45c05ac9f7f9c50e4c2cf068cefb8d3e4d6f78477ac5f9553ae8478c0438e0
EBUILD pytest-testinfra-6.5.0.ebuild 1205 BLAKE2B d83a040bd2d0ef6574868f4cd11aed122ba7d1e706780d1e900e652294124c06faeb6b655387fe314c092a7b9a310a89a6b5f7e6d1f3dc5cd0e211340a02ec6e SHA512 08d9b9ceb8c48be5aeff346272775aabd6e915776bf50261a8db9146f73e832eb18e68e86bc336c9cbc0211357a90e057643e7a80551891fe4e462dd9d2539ad
+EBUILD pytest-testinfra-6.6.0.ebuild 1240 BLAKE2B da9f1bf50090dcdc689931c5e29da618b771ca18a9560befe5e9b4d7c9a8f62105caa9ee01085ae9e9a9ac8cbe0d8d394736a00f33b031e2636329a4293e432d SHA512 c8770bd3050cd08b1da5e0f819f9c8342b805b358d5222babdc8f68d56fd8e241723e63c317fa7d235360f5cfe3323a7a4075b0a5dab03d252da11009805d300
MISC metadata.xml 680 BLAKE2B feb779de8bbaf041a3aa00046c4b17fcad0e863ebd365732c9f1e0bbdf6c68edf7ec2b7d546c2bdf458c134f7cb17a65ba07fe6edb5af7675d4bb79af75a23a6 SHA512 386a4877ca43ef6a1408ecc0871ba40c40b4654ee3824b4a99f5ff6f4769284d54c9377cebcd5456815fc5470110a337d83f8016a6598cef8ce29d93cd3645fc
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-6.6.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-6.6.0.ebuild
new file mode 100644
index 000000000000..562a2e01bbd7
--- /dev/null
+++ b/dev-python/pytest-testinfra/pytest-testinfra-6.6.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+HOMEPAGE="https://github.com/pytest-dev/pytest-testinfra"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+# Ansible is called via its CLI
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ <app-admin/ansible-5
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pywinrm[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ app-admin/salt[${PYTHON_USEDEP}]
+ ' python3_{8..9} )
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ if [[ ${EPYTHON} == "python3.10" ]]; then
+ ewarn "Some of the tests are skipped on ${EPYTHON} because it still isn't supported by app-admin/salt"
+ local EPYTEST_DESELECT=(
+ test/test_backends.py::test_backend_importables
+ )
+ fi
+ epytest
+}
+
+pkg_postinst() {
+ elog "For the list of available connection back-ends and their dependencies,"
+ elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
+}