summaryrefslogtreecommitdiff
path: root/dev-python/pytest-tempdir/pytest-tempdir-2019.10.12-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-03 03:10:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-03 03:10:55 +0000
commit670a2ef95331c60f32a0831bfe79445340356b0b (patch)
treecca4590ecf2c13488c7ef6c478f3e49acec2922d /dev-python/pytest-tempdir/pytest-tempdir-2019.10.12-r1.ebuild
parentd05150f06fa67b115a83f822b1e285dca011e1b7 (diff)
gentoo auto-resync : 03:11:2022 - 03:10:55
Diffstat (limited to 'dev-python/pytest-tempdir/pytest-tempdir-2019.10.12-r1.ebuild')
-rw-r--r--dev-python/pytest-tempdir/pytest-tempdir-2019.10.12-r1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/pytest-tempdir/pytest-tempdir-2019.10.12-r1.ebuild b/dev-python/pytest-tempdir/pytest-tempdir-2019.10.12-r1.ebuild
new file mode 100644
index 000000000000..d96260f5663f
--- /dev/null
+++ b/dev-python/pytest-tempdir/pytest-tempdir-2019.10.12-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin to support for a predictable and repeatable temporary directory"
+HOMEPAGE="https://github.com/saltstack/pytest-tempdir"
+SRC_URI="https://github.com/saltstack/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+distutils_enable_tests pytest