summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtests
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-python/pytest-subtests
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-python/pytest-subtests')
-rw-r--r--dev-python/pytest-subtests/Manifest2
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.6.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/Manifest b/dev-python/pytest-subtests/Manifest
index 9075c8e52ec4..0ebca46f771f 100644
--- a/dev-python/pytest-subtests/Manifest
+++ b/dev-python/pytest-subtests/Manifest
@@ -1,3 +1,5 @@
DIST pytest-subtests-0.5.0.tar.gz 9793 BLAKE2B c671eb14189c0fd34180a636592b20c9e2b4225c5faf3b702103164e60bdbac4c9644e464f1e0c783da3da1263f7b841ea7a4149bcbf1de23325a8ef3ce5c030 SHA512 e3d7e90c3ab66950eb80d25049bc6f6f75b08b3da5ce0de5f3fc55d6a176a8d1fdcb19a19f7d9d137aeadcc82b214550474f76d5611bc5592ca649ddd8257a2a
+DIST pytest-subtests-0.6.0.gh.tar.gz 9698 BLAKE2B 7b8f8c78ca503d107466d1ff34830aa08c3c5ec9b0f9e962b0e61472bf4f7413eb7e71db5768d898d476eb186a5a14c6703f14a990eb57c8664153a4ac384678 SHA512 9b4fa2e1957388f0e61a13a3cce95976fb5fdea64def627c5a1bf75049a0272e82f19ed9aa117bac0d02c6fd8832f22e7cfe409694ea81920def49742142eb93
EBUILD pytest-subtests-0.5.0-r1.ebuild 856 BLAKE2B b62cd02c2bb085da51ffc21e11c290a3a3b4aa1b28d8689872b4db6e427ad095c05c79c08debf2b1d30349519c54ca1c53b7cd9d0b1abcf8fceaa1b18431c651 SHA512 0fc9342070a13eba5dbf329179b077b6bb5232192d03b4f6ac0567cc9246429a92e4563de79ece32b5ad2e8016cb3d1589389f795dded5c332d343c51dbd6ed8
+EBUILD pytest-subtests-0.6.0.ebuild 1035 BLAKE2B 31ce4ca9dd32fc3475328b37c3540922b6aa29cba055830a58cc5fbab8694298a7e56be6e9a3453653756906a05d1ee04111366ee0805a25de636dd8b7472927 SHA512 7f7826cd69c7203b4cf6d37d5f31a697bcfca1c0550f55d493304ab7009bf89b6bd4be7fbf0a8772836155c801f07fd1dcc0725f1c6b6d3bcb704a7dbbad4f48
MISC metadata.xml 409 BLAKE2B ca267dc80fa124c3c8ba82f5e46356492e8cadefcf8001469c3c076b079844ae72829b5b527658bea341c3fee3f173421c9f2e7ec7042a171e234070113f4734 SHA512 57c12735a910107b53dbe54969f15ce70eafda3df096c78082d91d5bedc53b015ecae3e3d901e0a2a90841370916f6e4e94041e0b5589ffdce323144375e6c20
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.6.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.6.0.ebuild
new file mode 100644
index 000000000000..61159d2864ef
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-subtests/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked,pytest_subtests
+
+ distutils_install_for_testing
+ epytest
+}