summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtests/pytest-subtests-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-16 08:04:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-16 08:04:03 +0000
commit97f40b36b1afa9726e32962d11f3ac2d0bc5792e (patch)
tree1c7d586bc8a53d3b768630527bb80a477d661fa3 /dev-python/pytest-subtests/pytest-subtests-0.10.0.ebuild
parentb435e036d9775b71048373b91d4c7c3398826858 (diff)
gentoo auto-resync : 16:02:2023 - 08:04:02
Diffstat (limited to 'dev-python/pytest-subtests/pytest-subtests-0.10.0.ebuild')
-rw-r--r--dev-python/pytest-subtests/pytest-subtests-0.10.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-subtests/pytest-subtests-0.10.0.ebuild b/dev-python/pytest-subtests/pytest-subtests-0.10.0.ebuild
new file mode 100644
index 000000000000..82a381512d9d
--- /dev/null
+++ b/dev-python/pytest-subtests/pytest-subtests-0.10.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="unittest subTest() support and subtests fixture"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-subtests/
+ https://pypi.org/project/pytest-subtests/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-subtests/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7[${PYTHON_USEDEP}]
+"
+# pytest-xdist is used to test compatibility
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked,pytest_subtests
+ epytest
+}