summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtesthack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 14:31:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 14:31:38 +0100
commit9c26151d84a72781f240cc7ca3e2f0ab4ba60f74 (patch)
tree4ac39398cd519351bf12c6357e7474c508f19d13 /dev-python/pytest-subtesthack
parentb99d693f4d27fe2eb2237a0fe7e9c3b87d4d6df5 (diff)
gentoo auto-resync : 17:07:2022 - 14:31:38
Diffstat (limited to 'dev-python/pytest-subtesthack')
-rw-r--r--dev-python/pytest-subtesthack/Manifest2
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.2.0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-subtesthack/Manifest b/dev-python/pytest-subtesthack/Manifest
index 948650b02604..730b10b3ea76 100644
--- a/dev-python/pytest-subtesthack/Manifest
+++ b/dev-python/pytest-subtesthack/Manifest
@@ -1,3 +1,5 @@
DIST pytest-subtesthack-0.1.2.tar.gz 2669 BLAKE2B f1f5a052f9418732de4a97ff438d280d177860439e667e29ff0d0503740e009c88046b5ba859884e5fa9e958ea1be7388d7fc6838c19e44075ab0ef757ee41c7 SHA512 ddb7b0c27f912bec31e58ddc54930e229755df8980d146c861f7f1c766ae742b4f1552117d89638bdbd443f22890262320a56565954ebc6deeae6184f459a5a8
+DIST pytest-subtesthack-0.2.0.gh.tar.gz 2886 BLAKE2B e4e34ff73c7dfe92bed94d40fef168a3420879ba4a28eccb66ae7549d895b0ca7885be57178a6403661b57578f55ac3c5dbcaa090d2b658da770e0cabb0f3a75 SHA512 8b4f5ee2b07a8bcfa11934f5f207b9418810a708be7b8ccc0f19a4a4b979bbc60e993f0f2a5158482bc0162364bc96717e1ecda6743832ba121dfef9cfca9dd5
EBUILD pytest-subtesthack-0.1.2-r2.ebuild 709 BLAKE2B b27b30aea55a82a39625b76122c2f4bf0e7c46d6e37e7215b0eb6137332ea6de878f7903f1244780d7847c5c74cf4cc4f81e464daceb5e87f033b752c33d416b SHA512 a8020181f8584450567a34d05136607b916b578b339c8244302ebe46f43d588832a2597a3ab06783283453480724eff5102a7e6c8a2b580b8f34275461c780cb
+EBUILD pytest-subtesthack-0.2.0.ebuild 712 BLAKE2B 51fb76b0925e899bdd157510835c4a132a70f1c7f293987aa77a8fdb94df0c14bd80d2bb9dd5aea978432b0dc9114a31c2a95e6d8c886110424194b1e3205765 SHA512 81916fec65278aa15c17f12487b1ec316e61526756cbbb1a55fec4c3e0810b4a4285c1960d817efb1f0fa5dc9c3611ce07d4a04d876be7ab052f18a375c5bc1e
MISC metadata.xml 414 BLAKE2B 75bea5f93518f1e9b08ed1ad9f772c670bcf565f28b4a67c511fe919513741257fc5917f180ef31ed3e6d43b7986e8e1357ec456f9ddae4603baee1801dd6cc7 SHA512 5b4440d54b4ceb803ba5d9e4ea97fa38b777dbd1af02275f59011f727d9cb166427e8ed63b164b1891f6313349d49d31f4d7762e679439945a6ed4c24add6f46
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.2.0.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.2.0.ebuild
new file mode 100644
index 000000000000..734224e8f321
--- /dev/null
+++ b/dev-python/pytest-subtesthack/pytest-subtesthack-0.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A hack for test fixtures, needed for hypothesis inside py.test"
+HOMEPAGE="
+ https://github.com/untitaker/pytest-subtesthack/
+ https://pypi.org/project/pytest-subtesthack/
+"
+SRC_URI="
+ https://github.com/untitaker/pytest-subtesthack/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest