summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild')
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
index 8de886930db2..87ae193d0678 100644
--- a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
+++ b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
-PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
DESCRIPTION="A hack for test fixtures, needed for hypothesis inside py.test"
@@ -27,5 +29,5 @@ DEPEND="${RDEPEND}
python_test() {
distutils_install_for_testing
- py.test -v || die "Tests fail with ${EPYTHON}"
+ pytest -vv || die "Tests fail with ${EPYTHON}"
}