summaryrefslogtreecommitdiff
path: root/dev-python/pytest-skip-markers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/pytest-skip-markers
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/pytest-skip-markers')
-rw-r--r--dev-python/pytest-skip-markers/Manifest3
-rw-r--r--dev-python/pytest-skip-markers/metadata.xml11
-rw-r--r--dev-python/pytest-skip-markers/pytest-skip-markers-1.2.0.ebuild53
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pytest-skip-markers/Manifest b/dev-python/pytest-skip-markers/Manifest
new file mode 100644
index 000000000000..52b6f6eb19ad
--- /dev/null
+++ b/dev-python/pytest-skip-markers/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-skip-markers-1.2.0.tar.gz 79343 BLAKE2B 7f24b454fe19210d9ecadf10317a5a32830d722b64adbaf0fa6fad70a4c0cb598fa93b782a2b0f71bd23c4f91f2007d21383b488d725f61519d064e98ddd48f8 SHA512 76c1d0f0af7f7a56fa95d33bd5cb078792df3f054714d2ca1baa6d861e9404e2ec734a88a0768985388b1226c399ee6b54fe082ef7fcce6fc190fcae6201a416
+EBUILD pytest-skip-markers-1.2.0.ebuild 1519 BLAKE2B b5fc487ae418f4881ae612209e259b15a6c66b8a8eda0d201d90877cfa55872bc057319a4cc0dca2bade2ad302958a1ce2cf8400307a6c0751e51226f2cda064 SHA512 c6b032f12f2a81655eee78ccf203b48c7fbdb8302107a3942b1679adb1816d0902059ee3a1be296c3041766cc4d0ba8a44e47b3662978a45babdb61d5f1bcc27
+MISC metadata.xml 332 BLAKE2B 444e088c986bc7bcfa6ede30c807c1ada0a8c3dba264ebea0469df16858c0adae29bf5dfdc0ca6b1039ee02d092f6470156b161c88bb9f2bb03989f4ff117855 SHA512 b4251ca80a18902ed8be25eca4830de8fb9ce23bee47b013a992c1250a84788ccf82e5c6029d655884f71ff78feb1915482c9405882657f0b99846df01c174a8
diff --git a/dev-python/pytest-skip-markers/metadata.xml b/dev-python/pytest-skip-markers/metadata.xml
new file mode 100644
index 000000000000..fe019e56f6a8
--- /dev/null
+++ b/dev-python/pytest-skip-markers/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Patrick McLean</name>
+ <email>chutzpah@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-skip-markers</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-skip-markers/pytest-skip-markers-1.2.0.ebuild b/dev-python/pytest-skip-markers/pytest-skip-markers-1.2.0.ebuild
new file mode 100644
index 000000000000..a8de6b438280
--- /dev/null
+++ b/dev-python/pytest-skip-markers/pytest-skip-markers-1.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION=""
+HOMEPAGE="
+ https://pytest-skip-markers.readthedocs.io/en/latest/
+ https://github.com/saltstack/pytest-skip-markers
+"
+SRC_URI="https://github.com/saltstack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/pytest-tempdir[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-system-statistics[${PYTHON_USEDEP}]
+ dev-python/pytest-shell-utilities[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/setuptools-declarative-requirements[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
+ sed -e "/setuptools_scm/ d" -i setup.cfg || die
+ sed -e "s/tool.setuptools_scm/tool.disabled/" -i pyproject.toml || die
+
+ printf '__version__ = "${PV}"\n' > src/pytestskipmarkers/version.py || die
+
+ distutils-r1_python_prepare_all
+}