summaryrefslogtreecommitdiff
path: root/dev-python/pytest-shutil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/pytest-shutil
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/pytest-shutil')
-rw-r--r--dev-python/pytest-shutil/Manifest2
-rw-r--r--dev-python/pytest-shutil/pytest-shutil-1.7.0-r1.ebuild12
2 files changed, 4 insertions, 10 deletions
diff --git a/dev-python/pytest-shutil/Manifest b/dev-python/pytest-shutil/Manifest
index 55982c677673..2ba801e9a000 100644
--- a/dev-python/pytest-shutil/Manifest
+++ b/dev-python/pytest-shutil/Manifest
@@ -1,3 +1,3 @@
DIST pytest-shutil-1.7.0.tar.gz 23497 BLAKE2B e13641491fb4bd448973b8004ac9ded2f9b7c412ea93af7f9206e5fc38ea7554073374116eeefc529d2ae35e8a25e678fef5a27089af89026077a72d11d6016d SHA512 3746c08b17834621a7142ed9d5915b5c348c13367f5b423b258d3471bcb9c9e983c61c25ca936f879b8b82f80512512b7f3ade5555c24a790c72b502e3f3d144
-EBUILD pytest-shutil-1.7.0-r1.ebuild 1281 BLAKE2B 560ef73907a797812e84d15dbf501a46ff08c24f854dc50480e2afaa92f58743b7d929ff1a718c13cb4a90421b15dd70544676de0dcac6f11234def35c351cf9 SHA512 124292e1f7352180491ced69b8090d43731d3e30ac3918867f95df811a5f8e4bfe45a443120a4e6f9fe8c864a69de8145e9c42b44852655b465c57a4eb29c49f
+EBUILD pytest-shutil-1.7.0-r1.ebuild 1179 BLAKE2B 4da7c3e77cc02a21419d7051c9707730831fb4a0bb35b86a56bf1232b17671a4b6fc30279340d9c2fb678c211361407f60029b244357d14efc677967921a816c SHA512 64c6ba86ffd5588f50aa4afa8aa41c05804c30797f75a5a2f0bc44a38a43a435c32209a4c40089c47c732ab075c71032b8a3db15421a037a13e7ef812e0f3151
MISC metadata.xml 732 BLAKE2B afaff2db22c6de29920621f7684dd9cf3a6a070e7d40c2a6ed56fef507fb6dd1ca1b1ac51f106a49c38a556f2c0be244df5c8bae90e71d3ab7d7e1556725d87d SHA512 27c9d4196ec0cad1aa20d3d04c47cc791c9ff19189fd7facf844067c2f81a9c1e00aeeafe2fc65e231fd7039c41eea16c67f6d0f0dcf06386f402ebde03e03ef
diff --git a/dev-python/pytest-shutil/pytest-shutil-1.7.0-r1.ebuild b/dev-python/pytest-shutil/pytest-shutil-1.7.0-r1.ebuild
index 7a36fd6f0175..cee304ff4f5f 100644
--- a/dev-python/pytest-shutil/pytest-shutil-1.7.0-r1.ebuild
+++ b/dev-python/pytest-shutil/pytest-shutil-1.7.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -14,8 +14,6 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/pytest[${PYTHON_USEDEP}]
@@ -36,15 +34,11 @@ BDEPEND="
dev-python/setuptools-git[${PYTHON_USEDEP}]
"
+distutils_enable_tests --install setup.py
+
python_prepare_all() {
# keeps trying to install this in tests
sed -i 's:path.py::' setup.py || die
distutils-r1_python_prepare_all
}
-
-python_test() {
- distutils_install_for_testing
-
- esetup.py test || die "Tests failed under ${EPYTHON}"
-}