summaryrefslogtreecommitdiff
path: root/dev-python/pytest-shell-utilities
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/pytest-shell-utilities
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/pytest-shell-utilities')
-rw-r--r--dev-python/pytest-shell-utilities/Manifest3
-rw-r--r--dev-python/pytest-shell-utilities/metadata.xml11
-rw-r--r--dev-python/pytest-shell-utilities/pytest-shell-utilities-1.0.5.ebuild46
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pytest-shell-utilities/Manifest b/dev-python/pytest-shell-utilities/Manifest
new file mode 100644
index 000000000000..6bdb66dd7b62
--- /dev/null
+++ b/dev-python/pytest-shell-utilities/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-shell-utilities-1.0.5.tar.gz 89489 BLAKE2B 9cd7f95c9c1691e19c320378d1c2a4e147cb6fdc35ec6f3c80dc288e70416fce67b60ac86427f1ad322b2c17de3cd762e483d63076fa291b4b7d22d7a29c9e45 SHA512 395107af9eaa13ef39d01858e1674b6dedddc2cf93b9aba61316fd8d847031e1b535cc3bf4f2899dbc7828609b7d45b500aad29bb47668be6e0453ac099e99e4
+EBUILD pytest-shell-utilities-1.0.5.ebuild 1304 BLAKE2B 28d74fec94d30a5357a5bbcffef4c36775f820e710461bed050f95d4d8ee47a386458f2bf86ab2ebb51585538bea0fec4e3b5e44a12437bc728dbc4df76e246b SHA512 491eb767646e338d5f4e18da297fc691010ab4f0779ca97c0e5a5cf9bf6b1b902cd43c9342f0cdbfff02e242d28214c7e597089518a9df2125070d56e3771c0a
+MISC metadata.xml 335 BLAKE2B 62e842ec4ec614a557cbe0360488a306fafb8db8c858615403965bbfa7766ee9388f4786c027b303e9e550b7104a3b600d678239feba18a66d77d46a51e2d33b SHA512 62b9164ddb9f3e2c9d3869027bf116bccdf3ec05f35ec6e8094fd4ab79d1ee5c142c810b2c47dc281e23b4aa0c1dfa8f48573d97ae7f45e001dbc0288203b1da
diff --git a/dev-python/pytest-shell-utilities/metadata.xml b/dev-python/pytest-shell-utilities/metadata.xml
new file mode 100644
index 000000000000..16b2592b889f
--- /dev/null
+++ b/dev-python/pytest-shell-utilities/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Patrick McLean</name>
+ <email>chutzpah@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-shell-utilities</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.0.5.ebuild b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.0.5.ebuild
new file mode 100644
index 000000000000..dc95817ce4f9
--- /dev/null
+++ b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.0.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin: fixtures and code to help with running shell commands on tests"
+HOMEPAGE="
+ https://pypi.org/project/pytest-shell-utilities/
+ https://github.com/saltstack/pytest-shell-utilities
+"
+SRC_URI="https://github.com/saltstack/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s/use_scm_version=True/version='${PV}'/" -i setup.py || die
+ sed -e "/setuptools_scm/ d" -i setup.cfg || die
+ sed -e "s/tool.setuptools_scm/tool.disabled/" -i pyproject.toml || die
+
+ printf '__version__ = "${PV}"\n' > src/pytestshellutils/version.py || die
+
+ distutils-r1_python_prepare_all
+}