summaryrefslogtreecommitdiff
path: root/dev-python/pytest-shell-utilities
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-24 11:40:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-24 11:40:42 +0000
commita625efe29cec7f7c437cf33a956ea99eed1e4bd9 (patch)
tree3132969a9e093b34d3bd91ee6110a1111a965630 /dev-python/pytest-shell-utilities
parent1ff514162358897632ab329134c6bc75af618f10 (diff)
gentoo auto-resync : 24:02:2024 - 11:40:42
Diffstat (limited to 'dev-python/pytest-shell-utilities')
-rw-r--r--dev-python/pytest-shell-utilities/Manifest2
-rw-r--r--dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-shell-utilities/Manifest b/dev-python/pytest-shell-utilities/Manifest
index c1d126faa401..f16374446b07 100644
--- a/dev-python/pytest-shell-utilities/Manifest
+++ b/dev-python/pytest-shell-utilities/Manifest
@@ -1,3 +1,5 @@
DIST pytest-shell-utilities-1.8.0.gh.tar.gz 79387 BLAKE2B 830e481996347a45aac357da8f98c8e9ee091a2bfd84af01a853abacde7fb9e10c451742cc8aa60cb8fed71e8176e43d95e17fbdd870f3f490334f5f6860e936 SHA512 817219983a77ad1685d4a70aae7a261e40dff095545a261bf527b756f763718ae5a841635600917f6c1c9d37df128ca1a9e2532a211cdf0c7ab89ab1ac083eff
+DIST pytest-shell-utilities-1.9.0.gh.tar.gz 79526 BLAKE2B e17b3903b8b3b9c2a8b3d708a1031c5b18beb4741006cec5cf2b8586fb1a86c0034e374927f09786dd036d01ae8811f4eacdaa28053d3205d19bb122211b6437 SHA512 532d82754d0133cc49e8f88e700b1e7469e32a829079536b886358ba15caa18ff30a8ed88e258116ce4302c4220dc986c0f254cef10561ffee81d1e399107dbf
EBUILD pytest-shell-utilities-1.8.0.ebuild 1073 BLAKE2B c39688b54c5503617238f1c98240aea42dd4b86d10e4155256e15c2e7bebb1905232454082aa0baca756805e0fee64e3aabe6389d73f24e666f142aebf0c1062 SHA512 1f942638e09908e7fb18f33b5b692fe8b0a1c3ff4b2c55d1f124f9c2dd2629f9a93c4030878e786b2cd7fe47d9ca7f2d13ab139bbfe513a9096c4dd931c7a760
+EBUILD pytest-shell-utilities-1.9.0.ebuild 1028 BLAKE2B 7504c4d9f4e9022dc4378129ac751b15cc7c65e56f8086e35db148976958ac7129f0bdeac73e4171d157321592768986f73235c573c65123c4a2ecf251edeb8f SHA512 3ad4a7f05422beb8614e6ccf05e5d83f9df674603c159125a3f8f8e12493b1454e90f27eb0809f019e957464469a0b0df67e58ba3a47e17da9eaa03c96441cc5
MISC metadata.xml 508 BLAKE2B a72a63a2ac42538d8e95c8714345bda8a30aa1ce72c29e756bd78447655aa0fc429366b71c3833c2e074a3027b66e94067810540f75368ecb42a10a2096a5706 SHA512 9226db1de4dd7e82a09921776462390e7d539541e955254a89ff455aea35ed47ddd957ae335253b538eb635293dc6226ba639e55f5f1a109db4f5dc5b5cde914
diff --git a/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.0.ebuild b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.0.ebuild
new file mode 100644
index 000000000000..e0d65b67ca38
--- /dev/null
+++ b/dev-python/pytest-shell-utilities/pytest-shell-utilities-1.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin: fixtures and code to help with running shell commands on tests"
+HOMEPAGE="
+ https://pypi.org/project/pytest-shell-utilities/
+ https://github.com/saltstack/pytest-shell-utilities/
+"
+SRC_URI="
+ https://github.com/saltstack/pytest-shell-utilities/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.4.0[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}