summaryrefslogtreecommitdiff
path: root/dev-python/pytest-reserial
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-30 17:49:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-30 17:49:05 +0000
commit28d8acbb30a9ebda81447e5e3f5210a438ba7d24 (patch)
tree6d6b6b0a1aca19e8118845870c9e6a25bad27963 /dev-python/pytest-reserial
parent840a65e2af3f2cc7527e723a28f6e627a9592fb7 (diff)
gentoo auto-resync : 30:01:2024 - 17:49:05
Diffstat (limited to 'dev-python/pytest-reserial')
-rw-r--r--dev-python/pytest-reserial/Manifest3
-rw-r--r--dev-python/pytest-reserial/metadata.xml17
-rw-r--r--dev-python/pytest-reserial/pytest-reserial-0.2.4.ebuild27
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pytest-reserial/Manifest b/dev-python/pytest-reserial/Manifest
new file mode 100644
index 000000000000..daf66f363a0e
--- /dev/null
+++ b/dev-python/pytest-reserial/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-reserial-0.2.4.tar.gz 8420 BLAKE2B 7a3ffce0ac8b598551ddea29174f545e451ebf733e6bec50eb1cad4a5ed50cf10cf9279eabe2a33fc9feaf3e442880f6fd522258ab15232e25879a5f7fce4bd9 SHA512 532070460d48e0c840c3a22993907a32d811411a4499ecf50d233c063096fa8ac44f39d5fd5f60b9afe836209c4a24b3caca9193675fdb2b76af7cd9d7fffdca
+EBUILD pytest-reserial-0.2.4.ebuild 574 BLAKE2B 5427a266d0378e37e2dc265ba3899d431edb393a267fad48bbaa064f75e17b081459784b4ebcce58f53808fe4f471693269347ef215f7ae91e76e9f5fe501555 SHA512 c900037b8c46ae08ddafa06896b63fba0064fa0ce92a430c72a1a0ea98ae8180e7ed41fab8109fc595972e78c42560eeec47df069c01f24cff36ed328a27cd1e
+MISC metadata.xml 512 BLAKE2B c766f8d2a8c46e38b1cc274ee267458f8809b9a1bbdc4af9d5f7295ed81ae394c546c0287ecb864ed7e5c2b5a9a3b6a1efe1c21d6ab0714c4219f92db9926d3b SHA512 06f17659ccca9938a1f3ba49fdb81af3ee7358e6bc16587066ddbfbe6354bb2db68cd97abc5338b14d25bf547297697b83cccc5e99cf53712dcc3435eed07f6a
diff --git a/dev-python/pytest-reserial/metadata.xml b/dev-python/pytest-reserial/metadata.xml
new file mode 100644
index 000000000000..f35f2a9f1fe0
--- /dev/null
+++ b/dev-python/pytest-reserial/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pytest-reserial</remote-id>
+ <remote-id type="github">bessman/pytest-reserial</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-reserial/pytest-reserial-0.2.4.ebuild b/dev-python/pytest-reserial/pytest-reserial-0.2.4.ebuild
new file mode 100644
index 000000000000..85cb17e3e66c
--- /dev/null
+++ b/dev-python/pytest-reserial/pytest-reserial-0.2.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for recording and replaying serial port traffic during tests"
+HOMEPAGE="
+ https://pypi.org/project/pytest-reserial/
+ https://github.com/bessman/pytest-reserial/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest