summaryrefslogtreecommitdiff
path: root/dev-python/pytest-reserial/pytest-reserial-0.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-25 00:07:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-25 00:07:14 +0100
commitf8999218b5a6eafa151e7367030cbfdb69e045ed (patch)
tree0d0e9293bcb75153cd18542369fa789ede9338a0 /dev-python/pytest-reserial/pytest-reserial-0.4.1.ebuild
parentaa4954f71a3ba2293395a8cce2321a70c39c7554 (diff)
gentoo auto-resync : 25:05:2024 - 00:07:14
Diffstat (limited to 'dev-python/pytest-reserial/pytest-reserial-0.4.1.ebuild')
-rw-r--r--dev-python/pytest-reserial/pytest-reserial-0.4.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-reserial/pytest-reserial-0.4.1.ebuild b/dev-python/pytest-reserial/pytest-reserial-0.4.1.ebuild
new file mode 100644
index 000000000000..2735e3e0da22
--- /dev/null
+++ b/dev-python/pytest-reserial/pytest-reserial-0.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for recording and replaying serial port traffic during tests"
+HOMEPAGE="
+ https://pypi.org/project/pytest-reserial/
+ https://github.com/bessman/pytest-reserial/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest