summaryrefslogtreecommitdiff
path: root/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-25 20:05:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-25 20:05:44 +0000
commitd117172e3b48fc4be82b7623ffc40bb6070ef361 (patch)
tree20abd806f41d6a3c1699561a0f81279763e9253d /dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2-r1.ebuild
parent5950ab0f26bdbfcc40b68a19fd542816fecdd615 (diff)
gentoo auto-resync : 25:12:2022 - 20:05:44
Diffstat (limited to 'dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2-r1.ebuild')
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2-r1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2-r1.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2-r1.ebuild
deleted file mode 100644
index d87d0f5754ea..000000000000
--- a/dev-python/pytest-rerunfailures/pytest-rerunfailures-10.2-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-rerunfailures/
- https://pypi.org/project/pytest-rerunfailures/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MPL-2.0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_rerunfailures
- if has_version "dev-python/pytest-xdist[${PYTHON_USEDEP}]"; then
- PYTEST_PLUGINS+=,xdist.plugin
- fi
- epytest
-}