summaryrefslogtreecommitdiff
path: root/dev-python/pytest-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-01 20:42:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-01 20:42:22 +0000
commit721254b86a09bdedd5eefd0de7899c90ea2ead1a (patch)
tree895fca7b3bd570d8df743dd518a6f36deca1a241 /dev-python/pytest-qt
parent618c3037024b4e5328531cdc07c6ceb7486f5329 (diff)
gentoo resync : 01.01.2018
Diffstat (limited to 'dev-python/pytest-qt')
-rw-r--r--dev-python/pytest-qt/Manifest3
-rw-r--r--dev-python/pytest-qt/metadata.xml12
-rw-r--r--dev-python/pytest-qt/pytest-qt-2.3.0.ebuild44
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pytest-qt/Manifest b/dev-python/pytest-qt/Manifest
new file mode 100644
index 000000000000..4e4427c7d220
--- /dev/null
+++ b/dev-python/pytest-qt/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-qt-2.3.0.tar.gz 106707 BLAKE2B cf02aed42481cbcadfaaa15c883f3055337f6f32e33b7dfbce986ecd9936218ee5bfe9f21e1a910aa970e7adf88dd24415d63f40655e8417863e96a4285fd466 SHA512 2bda4b5f60ba68b151ce62972661cd704e40f4cadaef2583882099e96100b5c5b9398de796e851579e026e9736e07539c4db8c10eef16929ce729c4dd7a22940
+EBUILD pytest-qt-2.3.0.ebuild 900 BLAKE2B 06898d5289b9c14ed6376613618086bd718c59cd035c67e5e812587a29600c66e75158a8e0686e7348648a847ad5605a736c3eb243e23cdba15ac69a2d84c062 SHA512 9f720d5067e08d9fdb16a61524e6bdfc0891b3cbc485fb24f21b0945322e7ed52a2ce1162b0ce380e0d23e95745f48f56f257777c71d001c96199c3f2f3b85e4
+MISC metadata.xml 396 BLAKE2B f4d5cdd1823e62b7b0443623b9f34ffbd2f5f7944ddca44dacbeba2b4a3daa438203483b96f113ab821d4e5dccdc6e9cde8faa3a6a4a53d190b567af07cb9b61 SHA512 c5c3149a783a4d72eb7f0582d416b0f6c408d86878892a0ccde2aa5ec672a55c0c2658af31cffdd8f66500420fa3ee43dbda98397a1efb3cc06697e9e1af84ac
diff --git a/dev-python/pytest-qt/metadata.xml b/dev-python/pytest-qt/metadata.xml
new file mode 100644
index 000000000000..2b11b948e3b9
--- /dev/null
+++ b/dev-python/pytest-qt/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-qt</remote-id>
+ <remote-id type="github">pytest-dev/pytest-qt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild b/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild
new file mode 100644
index 000000000000..f99801f96289
--- /dev/null
+++ b/dev-python/pytest-qt/pytest-qt-2.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for PyQt4 or PyQt5 applications"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-qt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytest-2.7.0[${PYTHON_USEDEP}]
+ || (
+ dev-python/PyQt4
+ dev-python/PyQt5
+ )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]
+ )
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Test make assumptions about Qt environment
+RESTRICT="test"
+
+python_compile_all() {
+ use doc && sphinx-build -b html docs _build/html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( _build/html/. )
+ distutils-r1_python_install_all
+}