summaryrefslogtreecommitdiff
path: root/dev-python/pytest-pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pytest-pylint
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pytest-pylint')
-rw-r--r--dev-python/pytest-pylint/Manifest3
-rw-r--r--dev-python/pytest-pylint/metadata.xml10
-rw-r--r--dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild37
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pytest-pylint/Manifest b/dev-python/pytest-pylint/Manifest
new file mode 100644
index 000000000000..67b72268a7ff
--- /dev/null
+++ b/dev-python/pytest-pylint/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-pylint-0.7.1.tar.gz 5648 SHA256 2378eecfef82afc90430fbd578f65d35f6b9cf59319d75f826d9bc30922c5b28 SHA512 e2a7802f90ea25a909094e8bc67570eb631d6ab6dc130bb5cca1738ae09d069b4fa6c3c1349d9d62188a924138e832a3a37c8c5c8964290c95d69eecbadbd09f WHIRLPOOL 848102ab28293954b140a635ec9f0f6b41d3eb591fe00bd665912e689143431b78564316a17b388ad6044c2f4e7caf5c6dda1b1a498e3a20e6959de2f8d55b6d
+EBUILD pytest-pylint-0.7.1.ebuild 1018 SHA256 d6989e62774d2aec92c445edf406822bd2e032624266a96fdea31ec078195492 SHA512 cedfae9fbee109770bfe4b6308261de3a0c38326b073ff8f0bf619ab972ad0792dcc0f630427ed5bd51333a590e79887295fa19f657bdf2dcb90aa633717dbd3 WHIRLPOOL fbdd0e0e62e1d27a0df2ff2342472def97bde588cdef3af87112da2bfde69faa4af6ad0fb8265dd9b1650cddb640b4bb90877b75f96958994a3f2e0a28d26230
+MISC metadata.xml 306 SHA256 cc89da061c6348aa99ef0466d345929d35f88221dbdf9bcdd3d614597c2a7819 SHA512 726037520d25c038ab6a35c14edce11561e281fcfbb6a505bf3ead4d474cb10606b715f95c6df95e22e97f20f840c1694bde08984f9211bc46b5d0afb46f1c4e WHIRLPOOL eeeb27d1de21a2a7aaea6ac44b02ba2d87343adbc8c7f5de6f4f73df1c97e3940d3327bc90569bf541bbba4ecc5bade86ac0fdc5f131aba7ffa5d0345b254b89
diff --git a/dev-python/pytest-pylint/metadata.xml b/dev-python/pytest-pylint/metadata.xml
new file mode 100644
index 000000000000..0e3bc0471a62
--- /dev/null
+++ b/dev-python/pytest-pylint/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">carsongee/pytest-pylint</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild b/dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild
new file mode 100644
index 000000000000..d8c094245298
--- /dev/null
+++ b/dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to check source code with pylint"
+HOMEPAGE="https://github.com/carsongee/pytest-pylint"
+SRC_URI="https://github.com/carsongee/pytest-pylint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-pep8[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # pytest grabs the options from tox.ini automatically
+ # but setup.py does not declare pytest-pep8 as a dep,
+ # so it's missing from env created by distutils_install_for_testing
+ sed -i -e 's:--pep8::' tox.ini || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}