summaryrefslogtreecommitdiff
path: root/dev-python/pytest-pylint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pytest-pylint
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-pylint')
-rw-r--r--dev-python/pytest-pylint/Manifest3
-rw-r--r--dev-python/pytest-pylint/metadata.xml10
-rw-r--r--dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild37
3 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/pytest-pylint/Manifest b/dev-python/pytest-pylint/Manifest
deleted file mode 100644
index 01a4d0517064..000000000000
--- a/dev-python/pytest-pylint/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST pytest-pylint-0.7.1.tar.gz 5648 BLAKE2B 0baf011d9bbcfc5e66b8ea2c4fd95c8a3f8bbeedca15e2ec35d36b372b410d87ba619b0938acb26c667750c2f81d4bb09ca688731f9e184877fd999be04b6f26 SHA512 e2a7802f90ea25a909094e8bc67570eb631d6ab6dc130bb5cca1738ae09d069b4fa6c3c1349d9d62188a924138e832a3a37c8c5c8964290c95d69eecbadbd09f
-EBUILD pytest-pylint-0.7.1.ebuild 1018 BLAKE2B b06fbcd74138cbaa74467a5761b9fffb192f30f52d9e3ccf7a8755fc00576df48a58f5427b6214b9c7b12a3f17b290ce576bfcab900eca0bc38f98fdb853b6a5 SHA512 cedfae9fbee109770bfe4b6308261de3a0c38326b073ff8f0bf619ab972ad0792dcc0f630427ed5bd51333a590e79887295fa19f657bdf2dcb90aa633717dbd3
-MISC metadata.xml 306 BLAKE2B ef6d4e4bd779cdbec5e76617003defe8581c1c2b04b6098efce973a9b2eb154da51bdc27e8c202df1dc6c4a6393471b917dd47f2e95e75487dcba7a8fa725ae4 SHA512 726037520d25c038ab6a35c14edce11561e281fcfbb6a505bf3ead4d474cb10606b715f95c6df95e22e97f20f840c1694bde08984f9211bc46b5d0afb46f1c4e
diff --git a/dev-python/pytest-pylint/metadata.xml b/dev-python/pytest-pylint/metadata.xml
deleted file mode 100644
index 0e3bc0471a62..000000000000
--- a/dev-python/pytest-pylint/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- </maintainer>
- <upstream>
- <remote-id type="github">carsongee/pytest-pylint</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild b/dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild
deleted file mode 100644
index d8c094245298..000000000000
--- a/dev-python/pytest-pylint/pytest-pylint-0.7.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1
-
-DESCRIPTION="pytest plugin to check source code with pylint"
-HOMEPAGE="https://github.com/carsongee/pytest-pylint"
-SRC_URI="https://github.com/carsongee/pytest-pylint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-pep8[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # pytest grabs the options from tox.ini automatically
- # but setup.py does not declare pytest-pep8 as a dep,
- # so it's missing from env created by distutils_install_for_testing
- sed -i -e 's:--pep8::' tox.ini || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
- py.test -v || die "Tests fail with ${EPYTHON}"
-}