summaryrefslogtreecommitdiff
path: root/dev-python/pytest-param-files/pytest-param-files-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-30 22:42:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-30 22:42:58 +0100
commit3b4199328e240d392ef1f03900219cb88bdafcff (patch)
tree06007a008d485a5e0a169f2807b68f456e9df1b3 /dev-python/pytest-param-files/pytest-param-files-0.6.0.ebuild
parentaca0af8133e724b7edf0b5c6efe12c39077a3dc9 (diff)
gentoo auto-resync : 30:07:2023 - 22:42:58
Diffstat (limited to 'dev-python/pytest-param-files/pytest-param-files-0.6.0.ebuild')
-rw-r--r--dev-python/pytest-param-files/pytest-param-files-0.6.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-param-files/pytest-param-files-0.6.0.ebuild b/dev-python/pytest-param-files/pytest-param-files-0.6.0.ebuild
new file mode 100644
index 000000000000..56a3121eaa66
--- /dev/null
+++ b/dev-python/pytest-param-files/pytest-param-files-0.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest parametrize decorators from external files."
+HOMEPAGE="
+ https://github.com/chrisjsewell/pytest-param-files/
+ https://pypi.org/project/pytest_param_files/
+"
+SRC_URI="
+ https://github.com/chrisjsewell/pytest-param-files/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.15[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest