summaryrefslogtreecommitdiff
path: root/dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild')
-rw-r--r--dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild b/dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild
index 5e0850cfa5ad..816bb8658910 100644
--- a/dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild
+++ b/dev-python/pytest-param-files/pytest-param-files-0.3.4.ebuild
@@ -3,13 +3,16 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
DESCRIPTION="Pytest parametrize decorators from external files."
-HOMEPAGE="https://pypi.org/project/pytest_param_files/
- https://github.com/chrisjsewell/pytest-param-files"
+HOMEPAGE="
+ https://github.com/chrisjsewell/pytest-param-files/
+ https://pypi.org/project/pytest_param_files/
+"
SRC_URI="
https://github.com/chrisjsewell/pytest-param-files/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
@@ -19,6 +22,8 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest