summaryrefslogtreecommitdiff
path: root/dev-python/pytest-order
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-05 23:26:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-05 23:26:20 +0100
commit2de9aaae9b6018544ada7f67e2229605e1ec4d04 (patch)
tree231bad5690196ca522285d446614a065879cc7d0 /dev-python/pytest-order
parent4274bed0c1f1fd06a654f5816e30d82059f4cc39 (diff)
gentoo auto-resync : 05:04:2023 - 23:26:20
Diffstat (limited to 'dev-python/pytest-order')
-rw-r--r--dev-python/pytest-order/Manifest3
-rw-r--r--dev-python/pytest-order/metadata.xml13
-rw-r--r--dev-python/pytest-order/pytest-order-1.1.0.ebuild34
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pytest-order/Manifest b/dev-python/pytest-order/Manifest
new file mode 100644
index 000000000000..35d7259a3eb1
--- /dev/null
+++ b/dev-python/pytest-order/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-order-1.1.0.tar.gz 43385 BLAKE2B e0bb40d89dbbb382dec2828d024b9a9a8353c87a89d0d9fce517df2be248dc3d9f24672a91f6a9dd82e473d41fb677cc13ef1201563e25402288d5144a8742c0 SHA512 0ce0e0b0437031e672acb838f9e2bb40c2ee8afcc8463c779959309ace125b3a4c92efcf5e156c97037fa6b8d51c255e7cf272427e44587608c2a370289dd3c3
+EBUILD pytest-order-1.1.0.ebuild 974 BLAKE2B 8f881ec7c05d8db92d5d66e86b542719533179cc969c48690f44c10145732ed975d92577a6d8937b3e3f0935541036418349afdc3251c3b31ed3fa4370d7e6bb SHA512 c5f51a7c6c5bc97c10ab7e9c40c104c414fbdca2cfe3e2b915958347c4d0341e178889351a4e0e29c811240e2740772c2b501c15c31830f80dd6f39ea20e1c5c
+MISC metadata.xml 421 BLAKE2B 6b76a2376d1a001a247a842a493da9b341c9c355f0319072adaa55b20fa93397ed49f6ea6e965cd19bf3681e2a45bd9b34a9dadfc6bd59417fc88f3e04d19f4d SHA512 057e59a4e3e4d47f0b777531b6900a60516b2c26baf2a260b4fe34693c4568f77be45da02eb5b78dae27891845b0e6a7fcf4f9a0cdb59ee45e8ed54537795e8a
diff --git a/dev-python/pytest-order/metadata.xml b/dev-python/pytest-order/metadata.xml
new file mode 100644
index 000000000000..f46411ababd4
--- /dev/null
+++ b/dev-python/pytest-order/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">pytest-dev/pytest-order</remote-id>
+ <remote-id type="pypi">pytest-order</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-order/pytest-order-1.1.0.ebuild b/dev-python/pytest-order/pytest-order-1.1.0.ebuild
new file mode 100644
index 000000000000..d5434216c219
--- /dev/null
+++ b/dev-python/pytest-order/pytest-order-1.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin to run your tests in a specific order"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-order
+ https://pypi.org/project/pytest-order/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/pytest-6.4.2[${PYTHON_USEDEP}]"
+
+EPYTEST_DESELECT=(
+ # Appears to fail due to extra warning in pytest 7
+ "tests/test_dependency.py::test_order_dependencies_no_auto_mark"
+ "tests/test_dependency.py::test_order_dependencies_auto_mark"
+ "tests/test_order_group_scope_dep.py::test_class_group_scope_module_scope"
+ "tests/test_order_group_scope_named_dep.py::test_class_group_scope_module_scope"
+ "tests/test_xdist_handling.py::test_xdist_ordering"
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source